Tautology poj3295

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12475 Accepted: 4749

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example,ApNp is a tautology because it is true regardless of the value of p. On the other hand,ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not




#include <iostream>
#include <cstring>
#include <stack>

using namespace std;

int q,p,r,s,t;
char str[120];
stack <int> st;

bool acc()
{
    int len,i;
    int w,x;
    len = strlen(str);
    for(i=len-1; i>=0; i--)  ///倒序入栈 出栈正好是顺序
    {
        if(str[i] == 'q')
        {
            st.push(q);
        }
        else if(str[i] == 's')
        {
            st.push(s);
        }
        else if(str[i] == 'p')
        {
            st.push(p);
        }
        else if(str[i] == 'r')
        {
            st.push(r);
        }
        else if(str[i] == 't')
        {
            st.push(t);
        }
        else if(str[i] == 'A') ///有1则1 或
        {
            w = st.top();
            st.pop();
            x = st.top();
            st.pop();
            if(w||x)
            {
                st.push(1);
            }
            else
            {
                st.push(0);
            }
        }
        else if(str[i] == 'K') ///有0则0 与
        {
            w = st.top();
            st.pop();
            x = st.top();
            st.pop();
            if(w&&x)
            {
                st.push(1);
            }
            else
            {
                st.push(0);
            }
        }
        else if(str[i] == 'N') /// 取反
        {
            w = st.top();
            st.pop();
            st.push(!w);
        }
        else if(str[i] == 'C') ///只有 1 0 为 0
        {
            w = st.top();
            st.pop();
            x = st.top();
            st.pop();
            if(w&&!x)
            {
                st.push(0);
            }
            else
            {
                st.push(1);
            }
        }
        else if(str[i] == 'E') ///相同为1
        {
            w = st.top();
            st.pop();
            x = st.top();
            st.pop();
            if(w == x)
            {
                st.push(1);
            }
            else
            {
                st.push(0);
            }
        }
    }

    if(st.top() == 1)
    {
        return 1;
    }
    return 0;
}

int main()
{
    while(cin>>str && str[0]!='0')
    {
        int flag = 1;
        for(q=0; q<=1; q++)
        {
            for(p=0; p<=1; p++)
            {
                for(r=0; r<=1; r++)
                {
                    for(s=0; s<=1; s++)
                    {
                        for(t=0; t<=1; t++)  ///直接暴力枚举
                        {
                            bool out = acc();
                            if(out == 0)
                            {
                                flag = 0;
                            }
                        }
                    }
                }
            }
        }
        if(flag == 1)
        {
            cout<<"tautology"<<endl;
        }
        else
        {
            cout<<"not"<<endl;
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值