River Hopscotch poj3258 (二分+贪心思想+最小值最大化)



River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12390 Accepted: 5306

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,N (0 ≤N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 <Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toMrocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance*before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

Input

Line 1: Three space-separated integers:L,N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removingM rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

/**

貌似和poj3273差不多
不过理解题意有点麻烦
给出L,n个点 其实是n+2个点 包括开始(0)和结束(L)
排序一下
给出m
删除m个点后 求得最小的俩石头之间的距离
就是有距离出发点0...dis[i]...L的石头
问 删除m个点之后 使得最小距离最大,求出最大值是多少

那么二分边界问题
上界就是 L-0 当n=m时成立
下界就是 min(dis[i]-dis[i-1]) 当m=0时成立

详细问题见下代码

**/
#include <algorithm>
#include <iostream>

using namespace std;
const int inf = 1e9;

int dis[50010];

int main()
{
    int L,i;
    int n,m;
    int low,high,cnt,sum;
    while(cin>>L>>n>>m)
    {
        dis[0] = 0;
        low = inf;

        for(i=1; i<=n; i++)
        {
            cin>>dis[i];
        }
        dis[n+1] = L;
        sort(dis,dis+n+1);  ///排序一下 有点贪心思想
        high = L; ///上界
        for(i=1; i<=n+1; i++)
        {
            low = min(low,dis[i]-dis[i-1]);  ///求下界
        }
        while(low < high)
        {
            cnt=0; ///计删除的点数
            sum=0; ///记录两点之间跳跃距离
            int mid = (low+high)>>1;
            for(i=1; i<=n; i++)
            {
                if(sum+dis[i]-dis[i-1] <= mid)  ///距离小于mid 继续删除
                {
                    cnt++;                      ///类比3273
                    sum+=(dis[i]-dis[i-1]);     ///如果可以删除 那么sum这距离会变大 继续删除sum会继续加
                }
                else
                {
                    sum=0; ///跳跃距离目前为0了
                }
            }
            if(cnt <= m) ///当删除点m个时也不一定输出的最小距离最大
            {
                ///所以 继续进行二分右半边查找 找比较大的跳跃距离
                low = mid+1;
            }
            else
            {
                high = mid;
            }
        }
        cout<<low<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值