PAT甲级1020

题目描述#

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题意

给出一个颗二叉树的后序遍历序列和中序遍历序列,求该二叉树的层序遍历序列,输出末位没有空格。

解题代码

#include<cstdio>
#include<queue>
using namespace std;

int N;
const int maxn = 31;
int seq1[maxn];//seq1
int seq2[maxn];//seq2

struct node
{
	int data;
	node* lchild;
	node* rchild;
};//struct Nodes of b_tree

node* create(int postL, int postR, int inL, int inR)//function to create b_tree
{
	if (postL > postR) return NULL;

	int root_data = seq1[postR];
	int k;
	for (k = inL; k <= inR; k++)
		if (seq2[k] == root_data)
			break;
	node* Node = new node;//create a root node
	Node->data = root_data;
	int numL = k - inL;
	Node->lchild = create(postL, postL + numL - 1, inL, k - 1);
	Node->rchild = create(postL + numL, postR - 1, k + 1, inR);
	return Node;//return the addr. of root node
}

void print(node* root)
{
	queue<node*> q;//define a queue of node addr.
	q.push(root);//root node in que
	int num = 1;//no. of printed numbers
	while (!q.empty())
	{
		node* NODE = q.front();//access que_front ele.
		q.pop();//out que
		printf("%d", NODE->data);
		if (num != N)
		{
			printf(" ");
			num++;
		}
		if (NODE->lchild) q.push(NODE->lchild);//left-child existed, in que
		if (NODE->rchild) q.push(NODE->rchild);//right-child existed, in que
	}
}

int main()
{
	scanf("%d", &N);
	for (int i = 0; i < N; i++)
		scanf("%d", &seq1[i]);
	for (int i = 0; i < N; i++)
		scanf("%d", &seq2[i]);
	node* root = create(0, N - 1, 0, N - 1);
	print(root);
	return 0;
}

解题思路

首先,我们知道得到一棵完整的二叉树必须要知道该树的中序遍历,此题要求我们利用后序遍历序列和中序遍历序列去得到二叉树,因此需要研究一下这两个序列与根节点、左子树和右子树之间的关系。
图取自《算法笔记》图源于《算法笔记》
如图所示,假设递归过程中某步的后序遍历序列seq1区间为[postL,postR],中序遍历序列seq2区间为[inL,inR],则seq1[postR]即为二叉树的根节点。在seq2中找到与根节点数据相同的项,记下标为k。则左子树节点数为numL=k-inL。因此,左子树后序遍历序列区间为[postL,postL+numL-1],中序遍历序列区间为[inL,k-1];右子树后序遍历区间为[postL+numL,postR],中序遍历序列区间为[k+1,inR]。递归边界为序列长度为0(即postL>postR)。写进递归函数create,函数返回根节点地址。
层序遍历采用广度优先搜索(BFS),整个过程类似于队列。首先将根节点入队,然后在队列非空时访问队首元素(保存至临时结点后弹出),之后判断队首元素的左右子树是否为空,非空则将子树结点地址入队。因为队列元素为根节点地址,因此队列类型是node*。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值