ZOJ 1354 Extended Lights Out

17 篇文章 1 订阅
7 篇文章 0 订阅
该博客介绍了一个名为Extended Lights Out的益智游戏,玩家需要通过按下按钮改变相邻灯的状态,目标是让所有灯熄灭。游戏开始时,会给出5x6的初始灯状态。博主提供了一个程序来解决这个谜题,程序读取输入的初始灯状态,并输出需要按下的按钮位置(用1表示)。示例展示了两个不同的初始布局及其解决方案。
摘要由CSDN通过智能技术生成
Extended Lights Out

Time Limit: 2 Seconds       Memory Limit: 65536 KB

In an extended version of the game Lights Out , is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed, the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.

Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4, so that, in the end, its state is unchanged.


Note:

1. It does not matter what order the buttons are pressed.

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.


3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ��, all lights in the first 5 columns may be turned off.

Write a program to solve the puzzle.


Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0's or 1's separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially. 

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0's indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.


Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0


Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1


灯亮则5(也可能是3或4)个位置上有奇数个开关,否则有偶数个开关。
枚举第一行的开关情况,有了第一行就可以根据灯的亮与暗依次推出第二行第三行一直到第五行的开关情况
再根据推出的第五行的开关情况所对应的灯的亮暗与给出的第五行的灯泡情况进行比较从而判断出所求矩阵

代码如下:

#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

int a[8][8], b[8][8];
int counted(int i, int j)
{
    int cnt = 0;
    if(b[i][j])
        cnt++;
    if(b[i-1][j])
        cnt++;
    if(b[i][j+1])
        cnt++;
    if(b[i][j-1])
        cnt++;
    return cnt;
}
int DFS()
{
    for(int i = 1; i <= 4; i++)
        for(int j = 1; j <= 6; j++)
        {
            int cnt = counted(i, j);
            if(cnt % 2 == a[i][j])  // 如果周围开关数目与现有位置上的开关数的奇偶性相同,
                b[i+1][j] = 0;      // 则下一行相应位置为0(即:没有开关),否则为1
            else
                b[i+1][j] = 1;
        }
    for(int i = 1; i <= 6; i++)     
    {
        int cnt = counted(5, i);  // 如果推出的第五行的开关数所对应的灯的亮暗与给出的第五行的灯泡情况不相同,则返回0继续判断下种情况
        if(cnt % 2 != a[5][i])
            return 0;
    }
    return 1;
}
void light()  //枚举第一行的所有情况(2的6次方种情况)
{
    for(int i = 0; i < 2; i++)
    {
        b[1][1] = i;
        for(int i1 = 0; i1 < 2; i1++)
        {
            b[1][2] = i1;
            for(int i2 = 0; i2 < 2; i2++)
            {
                b[1][3] = i2;
                for(int i3 = 0; i3 < 2; i3++)
                {
                    b[1][4] = i3;
                    for(int i4 = 0; i4 < 2; i4++)
                    {
                        b[1][5] = i4;
                        for(int i5 = 0; i5 < 2; i5++)
                        {
                            b[1][6] = i5;
                            int flag = DFS();
                            if(flag)  // 如果找到则跳出
                                return ;
                        }
                    }
                }
            }
        }
    }
    puts("8");
}
int main()
{
#ifdef test
    freopen("in.txt", "r", stdin);
#endif
    int t, num = 0;
    scanf("%d", &t);
    while(t--)
    {
        for(int i = 1; i <= 5; i++)
            for(int j = 1; j <= 6; j++)
                scanf("%d", &a[i][j]);
        for(int i = 0; i < 8; i++)
            for(int j = 0; j < 8; j++)
                b[i][j] = 0;
        printf("PUZZLE #%d\n",++num);
        light();
        for(int i = 1; i <= 5; i++)
            for(int j = 1; j <= 6; j++)
                printf("%d%c", b[i][j], j != 6 ?' ':'\n');
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值