hdu 1312 Red and Black

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312点击打开链接

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11962    Accepted Submission(s): 7451


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

//bfs

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <queue>
#define maxn 25;
using namespace std;
typedef struct{
    int x, y;
}node;
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int vis[25][25];
char map[25][25];
queue <node> q;
int main()
{
    int m, n;
    while (scanf("%d%d", &n, &m)!=EOF && n && m){
        memset(vis, 0, sizeof(vis));
        while(!q.empty()) q.pop();
        int ans = 1;
        node start;
        for (int i = 0; i < m; i++){
            getchar();
            for (int j = 0; j < n; j++){
                scanf("%c", &map[i][j]);
                if (map[i][j] == '@'){
                    start.x = i;
                    start.y = j;
                }
            }
        }
        vis[start.x][start.y] = 1;
        q.push(start);
        while(!q.empty()){
            node tmp =q.front();
            q.pop();
            node news = tmp;
            for (int i = 0; i < 4; i++){
                news.x = tmp.x + dx[i];
                news.y = tmp.y + dy[i];
                if (vis[news.x][news.y] == 1) continue;
                if (news.x < 0 || news.x >= m || news.y < 0 || news.y >= n) continue;
                if (map[news.x][news.y] == '#') continue;
                if (map[news.x][news.y] == '.'){
                    vis[news.x][news.y] = 1;
                    ans += 1;
                    q.push(news);
                }
            }
        }
        printf("%d\n", ans);
    }
}


//dfs
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <math.h>
#define maxn 25
using namespace std;
typedef struct{
    int x, y;
}node;
char map[maxn][maxn];
int vis[maxn][maxn];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int m, n, ans;
void dfs(int a,int b){
    for (int i = 0; i < 4; i++){
        int newa = a + dx[i];
        int newb = b + dy[i];
        if (vis[newa][newb] == 1) continue;
        if (newa < 0 || newa >= m || newb < 0 || newb >= n) continue;
        if (map[newa][newb] == '#') continue;
        if (map[newa][newb] == '.'){
            vis[newa][newb] = 1;
            ans += 1;
            dfs(newa, newb);
            //vis[newa][newb] = 0;
        }
    }
}
int main()
{
    while (scanf("%d%d", &n, &m)!=EOF && n && m){
        memset(vis, 0, sizeof(vis));
        node start;
        ans = 1;
        for (int i = 0; i < m; i++){
            getchar();
            for (int j = 0; j < n; j++){
                scanf("%c", &map[i][j]);
                if (map[i][j] == '@'){
                    start.x = i;
                    start.y = j;
                }
            }
        }
        dfs(start.x, start.y);
        printf("%d\n", ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值