【BFS】poj 2386 Lake Counting

7 篇文章 0 订阅
Lake Counting
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 35654
Accepted: 17691

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

///AC代码
#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int m, n;
char str[105][105];
bool vis[105][105];
struct node
{
    int x, y;
};
int dix[8] = {1, -1, 0, 0, 1, -1, -1, 1};
int diy[8] = {0, 0, 1, -1, 1, -1, 1, -1};
int cango(int x, int y)
{
    return x >= 0 && x < m && y >= 0 && y < n && vis[x][y] == false;
}
int bfs(int x, int y)
{
    //pp++;
    queue<node> qu;
    node gg;
    gg.x = x;
    gg.y = y;
    qu.push(gg);
    memset(vis, false, sizeof(vis));
    vis[x][y] = true;
    str[x][y] = '.';
    int sum = 0;
    while (!qu.empty())
    {
        gg = qu.front();
        qu.pop();
        sum++;
        for (int i = 0; i < 8; i++)
        {
            int _x = gg.x + dix[i];
            int _y = gg.y + diy[i];
            if (cango(_x, _y) && str[_x][_y] == 'W')
            {
                node hh;
                hh.x = _x;
                hh.y = _y;
                qu.push(hh);
                vis[_x][_y] = true;
                str[_x][_y] = '.';
            }
        }
    }
    return sum;
}

int main()
{
    while (cin >> m >> n)
    {
        //memset(vis, false, sizeof(vis));
        int ans = 0, pp = 0;
        for (int i = 0; i < m; i++)
        {
            cin >> str[i];
        }
        for (int i = 0; i < m; i++)
        {
            for (int j = 0; j < n; j++)
            {
                if (str[i][j] == 'W')
                {
                    ans += bfs(i, j);
                    pp++;
                }
            }
        }
        //cout << ans << endl;
        cout << pp << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值