【BFS】hdu 2717 Catch That Cow

7 篇文章 0 订阅

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15172    Accepted Submission(s): 4566



Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 ///AC代码
#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int n, k;
bool vis[100001];
int dis[3] = {1, -1, 2};

int cango(int x)
{
    return x >= 0 && x < 100001 && vis[x] == false;
}

struct node
{
    int x, step;
};

int bfs(int n, int k)
{
    if (n == k)
    {
        return 0;
    }
    queue<node> qu;
    node gg;
    gg.x = n;
    gg.step = 0;
    qu.push(gg);
    memset(vis, false, sizeof(vis));
    vis[n] = true;

    while (!qu.empty())
    {
        gg = qu.front();
        qu.pop();

        if (gg.x == k)
        {
            return gg.step;
        }
        for (int i = 0; i < 3; i++)
        {
            int _x;
            if (i == 0 || i == 1)
            {
                _x = gg.x + dis[i];
            }
            else if (i == 2)
            {
                _x = gg.x * dis[i];
            }
            if (cango(_x))
            {
                node hh;
                hh.x = _x;
                hh.step = gg.step + 1;
                qu.push(hh);
                vis[_x] = true;
            }
        }
    }
    return -1;
}
int main()
{
    while (cin >> n >> k)
    {
        int ans = bfs(n, k);
        cout << ans << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值