【并查集】poj 2524 Ubiquitous Religions

Ubiquitous Religions

当今世界有很多不同的宗教,很难通晓他们。你有兴趣找出在你的大学里有多少种不同的宗教信仰。
你知道在你的大学里有n个学生(0 < n <= 50000) 。你无法询问每个学生的宗教信仰。此外,许多学生不想说出他们的信仰。避免这些问题的一个方法是问m(0 <= m <= n(n - 1)/ 2)对学生,问他们是否信仰相同的宗教(例如他们可能知道他们两个是否去了相同的教堂) 。在这个数据中,你可能不知道每个人信仰的宗教,但你可以知道校园里最多可能有多少个不同的宗教。假定每个学生最多信仰一个宗教。
Input
有多组数据。对于每组数据:
第一行:两个整数n和m。
以下m行:每行包含两个整数i和j,表示学生i和j信仰相同的宗教。学生编号从1到n。
输入的最后一行中,n = m = 0。
Output
对于每组测试数据,输出一行,输出数据序号( 从1开始)和大学里不同宗教的最大数量。(参见样例)
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
输入巨大,推荐使用scanf。


///AC代码

#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int pre[50010];
bool gg[50010];
int findd(int x)                           //查找根节点
{
    int r = x;
    while ( pre[r] != r )                //返回根节点 r
    {
        r = pre[r];
    }

    int i = x, j ;
    while ( i != r )                      //路径压缩
    {
        j = pre[i]; // 在改变上级之前用临时变量j记录下他的值
        pre[i] = r ; //把上级改为根节点
        i = j;
    }
    return r ;
}
void join(int x, int y)                    //判断x y是否连通,
//如果已经连通,就不用管了 //如果不连通,就把它们所在的连通分支合并起,
{
    int fx = findd(x), fy = findd(y);
    if (fx != fy)
    {
        pre[fx] = fy;
    }
}

int main()
{
    int n, m, hh = 0;
    while (~scanf("%d%d", &n, &m) && n + m)
    {
        int ans = 0;
        for (int i = 1; i <= n; i++)
        {
            pre[i] = i;
        }

        int x, y;
        for (int i = 1; i <= m; i++)
        {
            scanf("%d%d", &x, &y);
            join(x, y);
        }

        memset(gg, 0, sizeof(gg));
        for (int i = 1; i <= n; i++)
        {
            int x = findd(i);
            gg[x] = 1;
        }

        for (int i = 1; i <= n; i++)
        {
            if (gg[i] == 1 && findd(i) == i)
            {
                ans++;
            }
        }
        printf("Case %d: %d\n", ++hh, ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值