2017 Multi-University Training Contest - Team 2 1003 Maximum Sequence

27 篇文章 0 订阅

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1a2n . Just like always, there are some restrictions on an+1a2n : for each number ai , you must choose a number bk from {bi}, and it must satisfy ai ≤max{ aj -j│ bk ≤j<i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo 109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo 109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 

题意:

给出数列 A 和B

A代表着当前数列

B代表着从B[i]到整个A数列结束取最大的 (A[k]-k)添加到A的最后

问添加的数之和最大是多少


分析:

用样例来分析

a: 8 11 8 5

a[i]-i: 7  9  5  1

b:3 1 4 2

先将b排序得到  b: 1 2 3 4

那么取第一个b[0]=1 那么取到9

a:8 11 8 5 9

a[i]-i: 7 9 5 1 4

b[1]=2 还是取到 9

a: 8 11 8 5 9 9

a[i]-i: 7 9 5 1 4 3

后面继续这样取最终得到的是

a: 8 11 8 5 9 9 5 4  多出来的就是 27


那么从模拟的这个过程可以发现,只要记录当前位置到n中间的最大值 和更新出来的数中的最大值

进行比较取最大的那个,就是答案啦


#include<stdio.h>
#include<string.h>
#include<algorithm>
#define mod 1000000007
using namespace std;

long long a[300000], b[300000];
long long maxa[300000];
int main()
{
    int n;
    while (scanf("%d", &n) == 1)
    {
        memset(maxa, 0, sizeof(maxa));
        for (int i = 1; i <= n; i++)
        {
            long long aa;
            scanf("%lld", &aa);
            a[i] = aa - i;
        }
        for (int i = n; i >= 1; i--)      ///记录当前位置到n中间的最大值
        {
            maxa[i] = max(maxa[i + 1], a[i]);
        }
        for (int i = 1; i <= n; i++)
        {
            scanf("%lld", &b[i]);
        }
        sort(b + 1, b + n + 1);
        
        
        long long ans = 0;
        ans += maxa[b[1]];
        ans %= mod;
        
        
        long long t = maxa[b[1]] - (n + 1);
        for (int i = 2; i <= n; i++)
        {
            maxa[b[i]] = max(maxa[b[i]], t);
            ans += maxa[b[i]];
            ans %= mod;
            t = max(t, maxa[b[i]] - n - i);
        }
        printf("%lld\n", ans);
    }
}

数组开小了。。。a数组开2*250010,Sum数组应该开4*2*250010而不是4*250010。。。

赛时一直ttttttttt。。。很气  = =

简单的单点更新,区间求最值

线段树解法:

#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
#define M 1000000007
typedef long long ll;
using namespace std;
#define maxn 250010*2  //元素总个数
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

int Sum[maxn << 2], Add[maxn << 2]; //Sum求和,Add为懒惰标记
int a[maxn], n, b[maxn];

///建树:Build(1,n,1);
//PushUp函数更新节点信息 ,这里是求和
void PushUp(int rt)
{
    Sum[rt] = max(Sum[rt << 1], Sum[rt << 1 | 1]);
}
//Build函数建树
void Build(int l, int r, int rt) //l,r表示当前节点区间,rt表示当前节点编号
{
    if (l == r) //若到达叶节点
    {
        Sum[rt] = a[l]; //储存数组值
        return;
    }
    int m = (l + r) >> 1;
    //左右递归
    Build(l, m, rt << 1);
    Build(m + 1, r, rt << 1 | 1);
    //更新信息
    PushUp(rt);
}
///点修改,假设A[L]+=C: Update(L,C,1,n,1);
void Update(int L, int C, int l, int r, int rt) //l,r表示当前节点区间,rt表示当前节点编号
{
    if (l == r) //到叶节点,修改i
    {
        Sum[rt] = C;
        return;
    }
    int m = (l + r) >> 1;
    //根据条件判断往左子树调用还是往右
    if (L <= m)
    {
        Update(L, C, l, m, rt << 1);
    }
    else
    {
        Update(L, C, m + 1, r, rt << 1 | 1);
    }
    PushUp(rt);//子节点更新了,所以本节点也需要更新信息
}
///然后是区间查询的函数:int ANS=Query(L,R,1,n,1);  ^^^^^^^^^^查询[L,R]区间的最大/最小值^^^^^^^^^^^^^
int Query(int L, int R, int l, int r, int rt) //L,R表示操作区间,l,r表示当前节点区间,rt表示当前节点编号
{
    if (L <= l && r <= R)
    {
        //在区间内,直接返回
        return Sum[rt];
    }
    int m = (l + r) >> 1;

    //累计答案
    int ANS = 0;
    if (L <= m)
    {
        ANS = max(ANS, Query(L, R, l, m, rt << 1));
    }
    if (R >  m)
    {
        ANS = max(ANS, Query(L, R, m + 1, r, rt << 1 | 1));
    }
    return ANS;
}

int main()
{
    while (scanf("%d", &n) != EOF)
    {
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            a[i] = a[i] - i;
        }
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &b[i]);
        }

        Build(1, 2 * n, 1);
        sort(b + 1, b + n + 1);

        ll ans = 0;
        for (int i = 1; i <= n; i++)
        {
            int L, R;
            L = b[i];
            R = n + i - 1;
            int xx = Query(L, R, 1, 2 * n, 1);
            ans += xx;
            ans %= M;

            Update(R + 1, xx - (R + 1), 1, 2 * n, 1);
        }
        printf("%I64d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值