【CUGBACM15级BC第17场 B】hdu 5101 Select

70 篇文章 0 订阅

Select

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2112    Accepted Submission(s): 594


Problem Description
One day, Dudu, the most clever boy, heard of ACM/ICPC, which is a very interesting game. He wants to take part in the game. But as we all know, you can't get good result without teammates.
So, he needs to select two classmates as his teammates.
In this game, the IQ is very important, if you have low IQ you will WanTuo. Dudu's IQ is a given number k. We use an integer v[i] to represent the IQ of the ith classmate.
The sum of new two teammates' IQ must more than Dudu's IQ.
For some reason, Dudu don't want the two teammates comes from the same class.
Now, give you the status of classes, can you tell Dudu how many ways there are.
 

Input
There is a number T shows there are T test cases below. ( T20 )
For each test case , the first line contains two integers, n and k, which means the number of class and the IQ of Dudu. n ( 0n1000 ), k( 0k<231 ).
Then, there are n classes below, for each class, the first line contains an integer m, which means the number of the classmates in this class, and for next m lines, each line contains an integer v[i], which means there is a person whose iq is v[i] in this class. m( 0m100 ), v[i]( 0v[i ]<231 )
 

Output
For each test case, output a single integer.
 

Sample Input
  
  
1 3 1 1 2 1 2 2 1 1
 

Sample Output
  
  
5
 
题意是说从n个小组里的某两个小组中各选一个人,要求所选的两个人的IQ和必须大于k。问符合的情况有多少种。
答案=从所有数中选择的两个加和大于k的数的方案数-在同一个集合中选择的两个加和大于k的数的方案数
而对于同一个集合中选择的两个加和大于k的方案数是可以直接排序然后利用单调性快速统计出来的。
		————出题者

PS:注意答案可以超int,所以必须longlong...


#include <bits/stdc++.h>
#define _ ios_base::sync_with_stdio(0);cin.tie(0);
using namespace std;
typedef long long LL;

vector<LL> b;
int t, n;
LL a[1010][110];
int m[1010];
int main()
{
    _
    LL flag;
    while (~scanf("%d", &t))
    {
        while (t--)
        {
            scanf("%d%I64d", &n, &flag);
            b.clear();
            int sum_num = 0;
            for (int i = 0; i < n; i++)
            {
                scanf("%d", &m[i]);
                sum_num += m[i];
                for (int j = 0; j < m[i]; j++)
                {
                    scanf("%I64d", &a[i][j]);
                    b.push_back(a[i][j]);
                }
                sort(a[i], a[i] + m[i]);
            }
            sort(b.begin(), b.end());
            LL ans = 0, x, y;
            for (int i = 0; i < n; i++)
            {
                for (int j = 0; j < m[i]; j++)
                {
                    LL temp = a[i][j];
                    int tmp1 = lower_bound(b.begin(), b.end(), flag - temp + 1) - b.begin();
                    x = (int)b.size() - tmp1;
                    if (temp * 2 > flag)
                    {
                        x--;
                    }
                    int tmp2 = lower_bound(a[i], a[i] + m[i], flag - temp + 1) - a[i];
                    y = m[i] - tmp2;
                    if (temp * 2 > flag)
                    {
                        y--;
                    }
                    ans += (x - y);
                }
            }
            printf("%I64d\n", ans / 2);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值