【CUGBACM15级BC第21场 A】hdu 5138 CET-6 test

70 篇文章 0 订阅

CET-6 test

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 755    Accepted Submission(s): 550


Problem Description
Small W will take part in CET-6 test which will be held on December 20th . In order to pass it he must remember a lot of words.
He remembers the words according to Ebbinghaus memory curve method.
He separates the words into many lists. Every day he picks up a new list, and in the next 1st,2nd,4th,7th,15th day, he reviews this list.
So every day he has many lists to review. However he is so busy, he does not know which list should be reviewed in a certain day. Now he invites you to write a program to tell him which list should to be reviewed in a certain day.
Lists are numbered from 1. For example list 1 should be reviewed in the 2nd,3rd,5th,8th,16th day.
 

Input
Multi test cases (about 100), every case contains an integer n in a single line.
Please process to the end of file.

[Technical Specification]
2n100000
 

Output
For each n,output the list which should be reviewed in the nth day in ascending order.
 

Sample Input
  
  
2 100
 

Sample Output
  
  
1 85 93 96 98 99
 
水题随便搞搞
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <queue>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <bitset>
#include <cassert>
using namespace std;
typedef long long LL;

int a[5] = { -15, -7, -4, -2, -1};
int main()
{
    int n;
    while (~scanf("%d", &n))
    {
        int xx;
        for (int i = 0; i < 5; i++)
        {
            xx = n;
            if (xx + a[i] > 0)
            {
                if (i != 4)
                {
                    cout << xx + a[i] << " ";
                }
                else if (i == 4)
                {
                    cout << xx + a[i] << endl;
                }
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值