【CUGBACM15级BC第10场 A】hdu 5018 Revenge of Fibonacci

70 篇文章 0 订阅

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1288    Accepted Submission(s): 605


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
Fn = Fn-1 + Fn-2
with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
  
  
3 2 3 5 2 3 6 2 2 110
 

Sample Output
  
  
Yes No Yes
Hint
For the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…
 
题意:ab为斐波那契数列前两项,问你c 是不是斐波那契数列里面的数

思路:水题,直接模拟即可


#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int main()
{
    int t;
    ll a, b, c;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%lld %lld %lld", &a, &b, &c);
        if (c == a || c == b)
        {
            printf("Yes\n");
        }
        else if (c < a)
        {
            printf("No\n");
        }
        else
        {
            ll xx = a;
            int flag = 0;
            while (xx <= c)
            {
                if (xx == c)
                {
                    flag = 1;
                }
                xx = a + b;
                a = b;
                b = xx;
            }
            if (flag == 1)
            {
                printf("Yes\n");
            }
            else
            {
                printf("No\n");
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值