【2017 ACM/ICPC Asia Regional Shenyang Online 1004】hdu 6197 array array array

11 篇文章 0 订阅
10 篇文章 0 订阅

array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 431    Accepted Submission(s): 269


Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array A and a number k , if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2An .
1T20
1n105
0kn
1Ai105
 

Output
For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
 

Sample Input
  
  
3 4 1 1 4 3 7 5 2 4 1 3 1 2 6 1 1 4 3 5 4 6
 

Sample Output
  
  
A is a magic array. A is a magic array. A is not a magic array.
 

题意:给你一个长度为n的序列,你可以删除m个元素,使得这个序列变成一个单调上升或下降序列。
思路:就是求最长上升或下降子序列长度是不是大于n-k
#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <algorithm>
#define N 100010
using namespace std;
const long long mod = 1000000007;

int numb[N], dp[N], numa[N];
int BiSearch(int len, int key)  //二分法
{
    int l = 0, r = len - 1;
    while (l <= r)
    {
        int mid = (l + r) / 2;
        if (dp[mid] > key)
        {
            r = mid - 1;
        }
        else if (dp[mid] < key)
        {
            l = mid + 1;
        }
        else
        {
            return mid;
        }
    }
    return l;
}
int main()
{
    cin.sync_with_stdio(false);
    int n, m, T;
    cin >> T;
    while (T--)
    {
        cin >> n >> m;
        for (int i = 0; i < n; i++)
        {
            cin >> numa[i];
            numb[i] = -numa[i];
        }


        int len = 1;
        dp[0] = numa[0];
        for (int i = 1; i < n; i++)
        {
            if (numa[i] > dp[len - 1])
            {
                dp[len] = numa[i];
                len++;
            }
            else
            {
                int pos = BiSearch(len, numa[i]);
                dp[pos] = numa[i];
            }
        }
        int lena = len;


        len = 1;
        dp[0] = numb[0];
        for (int i = 1; i < n; i++)
        {
            if (numb[i] > dp[len - 1])
            {
                dp[len] = numb[i];
                len++;
            }
            else
            {
                int pos = BiSearch(len, numb[i]);
                dp[pos] = numb[i];
            }
        }
        int lenb = len;


        if (n == m || n - m <= lena || n - m <= lenb)
        {
            cout << "A is a magic array." << endl;
        }
        else
        {
            cout << "A is not a magic array." << endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值