【CUGBACM15级BC第36场 B】hdu 5199 Gunner

70 篇文章 0 订阅
27 篇文章 0 订阅

Gunner

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1893    Accepted Submission(s): 852


Problem Description
Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The ith bird stands on the top of the ith tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height H will falls.
Jack will shot many times, he wants to know how many birds fall during each shot.

a bullet can hit many birds, as long as they stand on the top of the tree with height of H .
 

Input
There are multiple test cases (about 5), every case gives n,m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h [1],h [2],h [3],,h [n]        which describes the height of the trees.

In the third line, there are m numbers q [1],q [2],q [3],,q[m]         which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

1n,m1000000(106)

1h[i ],q[i ]1000000000(109)

All inputs are integers.
 

Output
For each q[i ] , output an integer in a single line indicates the number of birds Jack shot down.
 

Sample Input
  
  
4 3 1 2 3 4 1 1 4
 

Sample Output
  
  
1 0 1
Hint
Huge input, fast IO is recommended.
 

题意:有n课树,每棵树上有一只鸟站在树的顶端,给出每棵树的高度

猎人依次从m个高度射出一颗子弹,问每次能射死几只鸟

分析:
map的应用

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
#define N 1000005

map<int, int> ma;
int main()
{
    int n, m, t;
    while (~scanf("%d %d", &n, &m))
    {
        ma.clear();
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &t);
            ma[t]++;
        }
        for (int i = 1; i <= m; i++)
        {
            scanf("%d", &t);
            printf("%d\n", ma[t]);
            ma[t] = 0;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值