【CUGBACM15级BC第四场 B】hdu 4932 Miaomiao's Geometry

70 篇文章 0 订阅

Miaomiao's Geometry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2443    Accepted Submission(s): 600


Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.

There are 2 limits:

1.A point is convered if there is a segments T , the point is the left end or the right end of T.
2.The length of the intersection of any two segments equals zero.

For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn't equals zero), [1 , 3] and [3 , 4] are not(not the same length).

Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.

For your information , the point can't coincidently at the same position.
 

Input
There are several test cases.
There is a number T ( T <= 50 ) on the first line which shows the number of test cases.
For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.
On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 

Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 

Sample Input
  
  
3 3 1 2 3 3 1 2 4 4 1 9 100 10
 

Sample Output
  
  
1.000 2.000 8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1. For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2. For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
 

题意:给定x轴上一些点(不重复),现在要选一个线段,使得能放进这些区间中,保证线段不跨过点(即线段上只能是最左边或最右边是点),并且没有线段相交,求能放进去的最大线段

思路:推理一下,只有两点之间的线段,还有线段的一半可能符合题意,然后对于每种线段,去判断一下能不能成功放进去,这步用贪心,优先放左边,不行再放右边

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    double b[120], c[60];
    int flag[60];
    int n, i, j, T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        for (i = 0; i < n; i++)
        {
            scanf("%lf", &c[i]);
        }
        sort(c, c + n);
        int m = 0;
        for (i = 1; i < n; i++)
        {
            b[m++] = c[i] - c[i - 1];
            b[m++] = (c[i] - c[i - 1]) / 2;
        }
        sort(b, b + m);


        double ans;
        for (i = m - 1; i >= 0; i--)
        {
            memset(flag, 0, sizeof(flag));
            flag[0] = 1;
            double tmp = b[i];
            for (j = 1; j < n - 1; j++)
            {
                if (c[j] - tmp < c[j - 1] && c[j] + tmp > c[j + 1])
                {
                    break;
                }

                if (c[j] - tmp >= c[j - 1])
                {
                    if (flag[j - 1] == 2)
                    {
                        if (c[j] - c[j - 1] == tmp)
                        {
                            flag[j] = 1;
                        }
                        else if (c[j] - c[j - 1] >= 2 * tmp)
                        {
                            flag[j] = 1;
                        }
                        else if (c[j] + tmp <= c[j + 1])
                        {
                            flag[j] = 2;
                        }
                        else
                        {
                            break;
                        }
                    }
                    else
                    {
                        flag[j] = 1;
                    }
                }
                else if (c[j] + tmp <= c[j + 1])
                {
                    flag[j] = 2;
                }
            }
            
            
            if (j == n - 1)
            {
                ans = tmp;
                break;
            }
        }
        printf("%.3lf\n", double(ans));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值