【2017 ACM/ICPC Asia Regional Qingdao Online 1009】hdu 6214 Smallest Minimum Cut

10 篇文章 0 订阅

Smallest Minimum Cut

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 269    Accepted Submission(s): 76


Problem Description
Consider a network G=(V,E ) with source s and sink t . An s-t cut is a partition of nodes set V into two parts such that s and t belong to different parts. The cut set is the subset of E with all edges connecting nodes in different parts. A minimum cut is the one whose cut set has the minimum summation of capacities. The size of a cut is the number of edges in the cut set. Please calculate the smallest size of all minimum cuts.
 

Input
The input contains several test cases and the first line is the total number of cases T (1T300) .
Each case describes a network G , and the first line contains two integers n (2n200) and m (0m1000) indicating the sizes of nodes and edges. All nodes in the network are labelled from 1 to n .
The second line contains two different integers s and t (1s,tn) corresponding to the source and sink.
Each of the next m lines contains three integers u,v and w (1w255)   describing a directed edge from node u to v with capacity w .
 

Output
For each test case, output the smallest size of all minimum cuts in a line.
 

Sample Input
  
  
2 4 5 1 4 1 2 3 1 3 1 2 3 1 2 4 1 3 4 2 4 5 1 4 1 2 3 1 3 1 2 3 1 2 4 1 3 4 3
 

Sample Output
  
  
2 3
 
题意:
求最小割边数,模板题

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const __int64 inf = 10000000000000LL;
const int maxn = 100010;

int head[maxn], tol, dep[maxn], n;
struct node
{
    int from, to, next;
    __int64 cap;
} edge[1000000];
void add(int u, int v, __int64 cap)
{
    edge[tol] = (node)
    {
        u, v, head[u], cap
    };
    head[u] = tol++;
    edge[tol] = (node)
    {
        v, u, head[v], 0
    };
    head[v] = tol++;
}
int bfs(int s, int t)
{
    int que[maxn], front = 0, rear = 0;
    memset(dep, -1, sizeof(dep));
    dep[s] = 0;
    que[rear++] = s;
    while (front != rear)
    {
        int u = que[front++];
        front %= maxn;
        for (int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].to;
            if (edge[i].cap > 0 && dep[v] == -1)
            {
                dep[v] = dep[u] + 1;
                que[rear++] = v;
                rear %= maxn;
                if (v == t)
                {
                    return 1;
                }
            }
        }
    }
    return 0;
}
__int64 dinic(int s, int t)
{
    __int64 res = 0;
    while (bfs(s, t))
    {
        int Stack[maxn], top, cur[maxn];
        memcpy(cur, head, sizeof(head));
        top = 0;
        int u = s;
        while (1)
        {
            if (t == u)
            {
                __int64 min = inf;
                int loc;
                for (int i = 0; i < top; i++)
                    if (min > edge[Stack[i]].cap)
                    {
                        min = edge[Stack[i]].cap;
                        loc = i;
                    }
                for (int i = 0; i < top; i++)
                {
                    edge[Stack[i]].cap -= min;
                    edge[Stack[i] ^ 1].cap += min;
                }
                res += min;
                top = loc;
                u = edge[Stack[top]].from;
            }
            for (int i = cur[u]; i != -1; cur[u] = i = edge[i].next)
                if (dep[edge[i].to] == dep[u] + 1 && edge[i].cap > 0)
                {
                    break;
                }
            if (cur[u] != -1)
            {
                Stack[top++] = cur[u];
                u = edge[cur[u]].to;
            }
            else
            {
                if (top == 0)
                {
                    break;
                }
                dep[u] = -1;
                u = edge[Stack[--top]].from;
            }
        }
    }
    return res;
}
int main()
{
    int i, j, m, T, s, t;
    __int64 k;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &m);
        scanf("%d%d", &s, &t);
        memset(head, -1, sizeof(head));
        tol = 0;
        while (m--)
        {
            scanf("%d%d%I64d", &i, &j, &k);
            add(i, j, k * 200001 + 1);
            //add(j, i, k * 200001 + 1);
            add(j, i, 0);
        }
        __int64 ans = dinic(s, t);
        cout << ans % 200001 << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值