【2017 ACM/ICPC Asia Regional Qingdao Online 1011】hdu 6216 A Cubic number and A Cubic Number

11 篇文章 0 订阅
10 篇文章 0 订阅

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 148    Accepted Submission(s): 89


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27   so 27 is a cubic number. The first few cubic numbers are 1,8,27,64    and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100)   which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012 ) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO NO
 

题目大意:

给出一个p,p是素数(2 <= p <=1e12),判断是否存在正整数a,b使得a*a*a - b*b*b = p

如果存在输出YES,否则输出NO

我们知道立方差公式:a*a*a  - b*b*b = (a-b)(a*a+a*b+b*b)  

我们知道a*a*a - b*b*b = prime(素数)

所以(a-b)(a*a+a*b+b*b)  = prime;

由因为prime 只能由1*prime得来,所以prime = 1*prime

所以(a-b) = 1, (a*a+a*b+b*b) = prime , 所以a,b必是两个相邻的整数
所以预处理+二分即可

#include<bits/stdc++.h>
#include <ctime>
using namespace std;
typedef long long ll;
const int MAXN = 1 * 1e5 + 500;
const ll M = 1e9 + 7;

vector<ll> v;
ll sum(ll x)
{
    return x * x * x;
}
void init()
{
    ll limt = 1e12 + 1;
    for (int i = 2;; i++)
    {
        ll temp = sum(i) - sum(i - 1);
        if (temp > limt)
        {
            break;
        }
        v.push_back(temp);
    }
}
int main()
{
    ///clock_t start_time = clock();

    ///clock_t end_time = clock();
    ///cout << "Running time is: " << static_cast<double>(end_time - start_time) / CLOCKS_PER_SEC * 1000 << "ms" << endl;
    std::ios::sync_with_stdio(false);
    int t;
    cin >> t;
    init();
    while (t--)
    {
        ll p;
        cin >> p;
        ll flag = v[lower_bound(v.begin(), v.end(), p) - v.begin()];
        if (p != flag)
        {
            cout << "NO" << endl;
        }
        else
        {
            cout << "YES" << endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值