【自适应Simpson积分】hdu 1724 Ellipse

34 篇文章 0 订阅
8 篇文章 0 订阅

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1013    Accepted Submission(s): 363


Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:



A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )
 

Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
 

Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.
 

Sample Input
  
  
2 2 1 -2 2 2 1 0 2
 

Sample Output
  
  
6.283 3.142
 
题目大意:
给定四个实数a,b,l,r,求椭圆x^2/a^2+y^2/b^2=1与半平面x≥l和x≤r相交部分的面积
做法:
这一道题需要使用自适应Simpson积分法来求解函数的定积分
我们发现椭圆上下对称,所以题目所求的面积就是函数f(x)=sqrt(b^2(1−x^2/a^2))在区间[l,r]上的积分的2倍


#include<bits/stdc++.h>
#include <ctime>
using namespace std;
typedef long long ll;

double a, b;
double f(double x)           ///被积函数
{
    return b * sqrt(1.0 - x * x / (a * a));
}
double simpson(double a, double b)
{
    double c = a + (b - a) / 2;
    return (f(a) + 4 * f(c) + f(b)) * (b - a) / 6;
}
double asr(double a, double b, double epss, double A)
{
    double c = a + (b - a) / 2;
    double L = simpson(a, c) , R = simpson(c, b);
    if (fabs(L + R - A) <= 15 * epss)
    {
        return L + R + (L + R - A) / 15;
    }
    return asr(a, c, epss / 2, L) + asr(c, b, epss / 2, R);
}
double solve(double l, double r, double epss)
{
    return asr(l, r, epss, simpson(l, r));
}
int main()
{
    std::ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while (t--)
    {
        double l , r;
        cin >> a >> b >> l >> r;
        printf("%0.3f\n", solve(l, r, 1e-6));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值