POJ 1276 Cash Machine(多重背包)

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0


题目大意:每次测试数据的第一个数代表,要换的钱数s,第二个数n代表有多少种兑换的形式,以后有n组数,分别为面额和数目。



思路:因为每种钱都左右若干种数目,要使得得到最接近原始面值的需用使用多重背包解决。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
int sp[10010],num[10010];
int dp[100010],s;
void zeroonepack(int c,int p)
{
    for(int i=s;i>=c;i--)
        dp[i]=max(dp[i],dp[i-c]+p);
}
void complatepack(int c,int p)
{
    for(int i=c;i<=s;i++)
        dp[i]=max(dp[i],dp[i-c]+p);//减去费用加上价值
}
void multiplepack(int nu,int p,int c)
{
    if(s<=nu*p)//如果仅仅取当前一种类型的钱并且可以达到兑换的数目,进行完全背包
    {
        complatepack(c,p);//将此类型钱的面值传入函数
        return ;
    }
    else//否则的话转换成为01背包,主要是将一种物品的数目,划分为多组,每组进行01
    {//结果和原来的效果是相同的
        int tmp=1;
        while(tmp<=nu)
        {
            zeroonepack(tmp*c,tmp*p);
            nu-=tmp;
            tmp<<=1;
        }
        zeroonepack(nu*c,nu*p);
    }
}
int main()
{
    int  n,m,x,k,i,j;
    while(~scanf("%d",&s))
    {
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d %d",&num[i],&sp[i]);//不同种类的钱的数目,及其面值
        for(i=0;i<n;i++)//枚举每种类型钱
            multiplepack(num[i],sp[i],sp[i]);
        printf("%d\n",dp[s]);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值