HDOJ 2674 N!Again(找规律)

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120


题目大意:求n!%2009.

直接求解必定超时,能不能缩小范围呢,我刚开始想n%=2009但是确实没有证据这么做果然WA。但是%2009显然当阶乘到2009

以后的时候每次必有2009为因子,故一定为0,但阶乘的值太大,那么就可以想到什么时候阶乘可以达到含有2009这个因子,

2009=41*7*7所以40阶乘后全为0.


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define mod 2009
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    LL n,m,j,k;
    while(~scanf("%lld",&n))
    {
        k=1;
        if(n>40)
        {
            printf("0\n");continue;
        }
        for(int i=1;i<=n;i++)
        {
            k=(k%mod*i%mod)%mod;
        }
        printf("%lld\n",k);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值