HDU1548 A strange lift

马上蓝桥杯了,找了些bfs的题目练练手,因为作死报的java组,实在是有些惶恐
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

题目大意:有一个电梯总共有N层,一开始停在A层,需要到B层,这个电梯每一层都只能上或下ki层, 求至少多少次(电梯运行到一层就算一次)能到B,如果永远到不了,就输出“-1”。
解体思路:直接bfs,用状态数组vist表示之前是不是有状态已经访问过此位置,如果访问过,要不是死循环要不就是已经绕路不是最优解了,就不再往后面找结果。
贴java代码

import java.util.*;
public class Main {
    public static class pair{
    public  int first,second;
    public pair(int a,int b){
        first=a;
        second=b;
    }
    public pair(){

    }
    }
    public static pair make_pair(int a,int b){
        pair w=new pair(a,b);
        return w;
    }
public static void main(String[] args){
    Scanner in=new Scanner(System.in);
    int N,A,B;
    while(in.hasNext()){
        N=in.nextInt();
        if(N==0)
            break;
        A=in.nextInt();
        B=in.nextInt();
        int []k=new int [N+1];
        for(int i=1;i<=N;i++){
            k[i]=in.nextInt();
        }
        Queue<pair> qu=new LinkedList<pair>();
        boolean [] vist=new boolean [N+1];
        qu.offer(make_pair(A,0));
        boolean flag=false;
        vist[A]=true;
        while(!qu.isEmpty()){
            int po=qu.peek().first;
            int ans=qu.peek().second;
            qu.poll();
            if(po==B){
                flag=true;
                System.out.println(ans);
                break;
            }
            if(po+k[po]<=N&&!vist[po+k[po]]){
                qu.offer(make_pair(po+k[po],ans+1));
                vist[po+k[po]]=true;
            }
            if(po-k[po]>=1&&!vist[po-k[po]]){
                qu.offer(make_pair(po-k[po],ans+1));
                vist[po-k[po]]=true;
            }
        }
        if(!flag){
            System.out.println(-1);
        }
    }
}
}

习惯用c++,故直接写了个pair和make_pair,来简化代码。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值