CodeForces 145A

Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u  

Description

Petya loves lucky numbers very much. Everybody knows that lucky numbers are positive integers whose decimal record contains only the lucky digits 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Petya has two strings a and b of the same length n. The strings consist only of lucky digits. Petya can perform operations of two types:

  • replace any one digit from string a by its opposite (i.e., replace 4 by 7 and 7 by 4);
  • swap any pair of digits in string a.

Petya is interested in the minimum number of operations that are needed to make string a equal to string b. Help him with the task.

Input

The first and the second line contains strings a and b, correspondingly. Strings a and b have equal lengths and contain only lucky digits. The strings are not empty, their length does not exceed 105.

Output

Print on the single line the single number — the minimum number of operations needed to convert string a into string b.

Sample Input

Input
47
74
Output
1
Input
774
744
Output
1
Input
777
444
Output
3

Sample Output

Hint

In the first sample it is enough simply to swap the first and the second digit.

In the second sample we should replace the second digit with its opposite.

In the third number we should replace all three digits with their opposites.

同样的水题........

在第一个样品是足够简单的交换第一和第二位。

在第二个样本应与其相反的取代二位数

在第三号应与他们对立取代所有的三位数。

代码也就这样了

#include<iostream>
#include<cstring>
using namespace std;
char a[100010],b[100010];
int main()
{
    int flag1 = 0;
    int flag2 = 0;
    int i;
    cin>>a;
    cin>>b;
    for(i=0; a[i]!='\0'; i++)
    {
        if(a[i]!=b[i])
        {
            if(a[i]=='7')
            {
                flag1++;
            }
            if(a[i]=='4')
            {
                flag2++;
            }
        }
    }
    if(flag1>flag2)//找出最大的就OK了
        cout<<flag1<<endl;
    else
        cout<<flag2<<endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值