华为路由交换

园区网拓扑:

 

 

接入层:

port-group group-member g0/0/1 to g0/0/2

port link-type trunk
 port trunk allow-pass vlan 2 to 3

port-group group-member g0/0/3 to g0/0/10

port link-type access
 port default vlan 2
 stp edged-port enable        //端口加速
port-group group-member g0/0/11 to g0/0/19

port link-type access
 port default vlan 3
 stp edged-port enable

stp:

stp region-configuration
 region-name a1
 instance 1 vlan 2 to 4
 instance 2 vlan 5 to 7
 active region-configuration

其他接入层设备配置基本相同

汇聚层-1:

vlan batch 2 to 7 12 17 to 18 20 28        //创建vlan

stp instance 0 root secondary
stp instance 1 root primary
stp instance 2 root secondary        //定义组1 为根,组2为备份根

stp region-configuration
 region-name a1
 instance 1 vlan 2 to 4
 instance 2 vlan 5 to 7
 active region-configuration
 

interface Vlanif2
 ip address 10.0.1.1 255.255.255.0        //设置svi的ip地址
 vrrp vrid 1 virtual-ip 10.0.1.2        //设置vrrp的虚拟地址
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/6 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/7 reduced 15        //上行链路追踪
 dhcp select global

interface Vlanif5
 ip address 10.0.2.1 255.255.255.0
 vrrp vrid 1 virtual-ip 10.0.2.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/6 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/7 reduced 15

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 7

interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/5
 port link-type trunk
 port trunk allow-pass vlan 2 to 7        //下行链路配置

ospf配置:

ospf 1 router-id 3.3.3.3
 bfd all-interfaces enable
 bfd all-interfaces min-tx-interval 100 min-rx-interval 100
 silent-interface Vlanif2
 silent-interface Vlanif5
 spf-schedule-interval intelligent-timer 5000 500 1000
 lsa-originate-interval intelligent-timer 5000 200 1000
 area 0.0.0.0
 area 0.0.0.1
  stub

interface Vlanif12
 ip address 10.0.12.1 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif17
 ip address 10.0.17.1 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif18
 ip address 10.0.18.1 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1                //配置三层接口

interface Eth-Trunk12
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 2 to 7 12

interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 17
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 18
将svi划入物理接口

DHCP配置:

ip pool vlan2
 gateway-list 10.0.1.2
 network 10.0.1.0 mask 255.255.255.0
 excluded-ip-address 10.0.1.1
 excluded-ip-address 10.0.1.3
 excluded-ip-address 10.0.1.128 10.0.1.254        //排除地址
 dns-list 8.8.8.8

汇聚层-2

stp instance 0 root secondary
stp instance 1 root secondary
stp instance 2 root primary


stp region-configuration
 region-name a1
 instance 1 vlan 2 to 4
 instance 2 vlan 5 to 7
 active region-configuration


interface Vlanif2
 ip address 10.0.1.3 255.255.255.0
 vrrp vrid 1 virtual-ip 10.0.1.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/6 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/7 reduced 15
 dhcp select global
#
interface Vlanif5
 ip address 10.0.2.3 255.255.255.0
 vrrp vrid 1 virtual-ip 10.0.2.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/6 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/7 reduced 15
 dhcp select global
 

interface Vlanif12
 ip address 10.0.12.2 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif27
 ip address 10.0.27.2 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif28
 ip address 10.0.28.2 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface MEth0/0/1
#
interface Eth-Trunk12
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 2 to 7 12
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/3
 eth-trunk 12
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/5
 port link-type trunk
 port trunk allow-pass vlan 2 to 7
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 28
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 27

ospf 1 router-id 4.4.4.4
 bfd all-interfaces enable
 bfd all-interfaces min-tx-interval 100 min-rx-interval 100
 silent-interface Vlanif2
 silent-interface Vlanif5
 spf-schedule-interval intelligent-timer 5000 500 1000
 lsa-originate-interval intelligent-timer 5000 200 1000
 area 0.0.0.1
  stub
 

结果:

 核心层-1:

interface Vlanif17
 ip address 10.0.17.7 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif27
 ip address 10.0.27.7 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif78
 ip address 10.0.78.7 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
#
interface MEth0/0/1
#
interface Eth-Trunk12
 port link-type access
 port default vlan 78
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 17
#
interface GigabitEthernet0/0/2
 eth-trunk 12
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 27
#
interface GigabitEthernet0/0/4
 eth-trunk 12
 

ospf 1 router-id 2.2.2.2
 bfd all-interfaces enable
 bfd all-interfaces min-tx-interval 100 min-rx-interval 100
 spf-schedule-interval intelligent-timer 5000 500 1000
 lsa-originate-interval intelligent-timer 5000 200 1000
 area 0.0.0.0
  network 10.0.78.0 0.0.0.255
 area 0.0.0.1
  stub no-summary
#
user-interface con 0
user-interface vty 0 4
 

核心层-2::

interface Vlanif18
 ip address 10.0.18.8 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif28
 ip address 10.0.28.8 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
 ospf enable 1 area 0.0.0.1
#
interface Vlanif78
 ip address 10.0.78.8 255.255.255.0
 ospf network-type p2p
 ospf timer hello 1
#
interface MEth0/0/1
#
interface Eth-Trunk12
 port link-type access
 port default vlan 78
#
interface GigabitEthernet0/0/1
 eth-trunk 12
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 18
#
interface GigabitEthernet0/0/4
 eth-trunk 12

ospf 1 router-id 1.1.1.1
 bfd all-interfaces enable
 bfd all-interfaces min-tx-interval 100 min-rx-interval 100
 spf-schedule-interval intelligent-timer 5000 500 1000
 lsa-originate-interval intelligent-timer 5000 200 1000
 area 0.0.0.0
  network 10.0.78.0 0.0.0.255
 area 0.0.0.1
  stub no-summary
 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值