manjaro修复因降级OpenSSL导致pacman和sudo不能使用

降级是因为编译某个程序需要ssl1.0而1.1是使用不了的
原openssl版本:

[lxx@lxx-pc lxx]$ openssl version
OpenSSL 1.1.2h  3 May 2018

老版本下载地址:
file
安装(–force是强制安装):

sudo pacman -U ./openssl-1.0.2h-2-x86_64.pkg.tar.xz --force

降级成功openssl版本

[lxx@lxx-pc lxx]$ openssl version
OpenSSL 1.0.2h  3 May 2016

但是现在sudo 和 pacman 不能使用了,提示:

[lxx@lxx-pc lxx]$ sudo
sudo: 在加载插件“sudoers_policy”时在 /etc/sudo.conf0 行出错
sudo: 无法加载 /usr/lib/sudo/sudoers.so:libssl.so.1.1: 无法打开共享对象文件: 没有那个文件或目录
sudo: 致命错误,无法加载插件
[lxx@lxx-pc lxx]$ pacman
pacman: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory              

解决方法,下载保存对应版本的OpenSSL安装包,解压,把/usr/lib的文件(缺失的)复制到/lib文件夹里面
需要超级用户权限

# 登陆
su
cp /usr/lib/libssl.so.1.1 /lib/libssl.so.1.1
cp /usr/lib/libcrypto.so.1.1 /lib/libcrypto.so.1.1

完成

阅读更多

没有更多推荐了,返回首页