poj 1733 Parity game(离散化+带权并查集+二分查找)

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8355 Accepted: 3248

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source


题目大意,有一串由0和1组成的数,询问区间内1的个数是奇数还是偶数,判断前几个是没有冲突的(找出第一个出错的)

因为奇数加奇数等于偶数,偶数加奇数等于奇数,偶数加偶数等于偶数,所以按带权并查集的方式记录自己到结点的距离取膜2

当祖先一样时判断value[u]+w !=value[v]是否成立.

(find()的时候忘记取膜,wa了10多发。)

AC 代码

#include<stdio.h>
#include<string.h>
#include<map>
#include<algorithm> 
using namespace std;
int father[100200];//查错的时候看了一下谈论区,有人说数据按5K来开会出错,索性直接开大
int rank1[100200];
int value[100200];
struct tree
{
	int u,v,w;
	tree(){}
	tree(int uu,int vv,int ww)
	{
		u=uu,v=vv,w=ww;
	}
}p[55550];
int all[100200];
void init(int n)
{
	for(int i=0;i<=n;i++)
	{
		father[i]=i;
		rank1[i]=0;
		value[i]=0;
	}
}
int find(int x)
{
	if(x==father[x]) return x;
	int p=find(father[x]);
	value[x]=(value[x]+value[father[x]])%2;//这里不取膜的话,下面要先取膜再加2再取膜-》(c+value[b]-value[a])%2+2)%2;防为负
	return father[x]=p;
}
bool unite(int a,int b,int c)
{
	int aa=find(a);
	int bb=find(b);
	if(aa==bb) return false;
	if(rank1[aa]<rank1[bb])
	{
		father[aa]=bb;
		value[aa]=(c+value[b]+2-value[a])%2;
	}
	else
	{
		father[bb]=aa;
		value[bb]=(value[a]-value[b]-c+2)%2;
		if(rank1[aa]==rank1[bb])
		rank1[aa]++;
	}
	return true;
}
int main()
{
	int n,m;
	while(scanf("%d",&n)==1)
	{
		scanf("%d",&m);
		int cut=0;
		for(int i=0;i<m;i++)
		{
			int a,b;char c[20];
			scanf("%d%d%s",&a,&b,c);
			a--;
			p[i].u=a;p[i].v=b;p[i].w=c[0]=='e'?0:1; //貌似有人写反wa了的QAQ
			all[cut++]=a,all[cut++]=b;
		}
		sort(all,all+cut);
		cut=unique(all,all+cut)-all;  //去重函数(只是指针移动,数组内部的数并没有少,相同的推到了后面)
		init(cut);
		int flog=0;
		for(int i=0;i<m;i++)
		{
			int a=lower_bound(all,all+cut,p[i].u)-all,b=lower_bound(all,all+cut,p[i].v)-all;//二分优化时间
			if(!unite(a,b,p[i].w))
			{
				if((value[a]+p[i].w)%2!=value[b])
				{
					printf("%d\n",i);
					flog=1;
					break;
				}
			}
		}
		if(!flog)      //如果全部没有冲突的话要输出m
		printf("%d\n",m);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值