zoj 1530 Find The Multiple

 

Find The Multiple

Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.


Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero (0) terminates the input.


Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.


Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


Source: Asia 2002, Dhaka (Bengal)

 

题意:给你一个数n,让你找n的倍数m,m的十进制中只能有1和0,问最小的m是几。

思路若没有是n的倍数的条件,如何构造01序列?开一个队列,先把1放进去。然后取出1,把1*10,1*10+1放进去,以此类推是n的倍数只需要判断一下即可,但答案可能爆long logn,所以用同余定理 若a%b=c,那么ax%b=cx%b (x!=0),用字符数组记录01序列,同时记录这个01序列%n的余数。还有一个问题,空间消耗巨大,还是用同余定理:如果a%n=c,b%n=c,a<b,那么这个时候b就不用入队了,因为答案只看余数

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
struct nond{
    string s;
    int mod;
}cur,net;
int n;
bool vis[1000001];
int main(){
    while(1){
        queue<nond>que;
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        if(n==0)    break;
        cur.s="1";cur.mod=1;
        que.push(cur);
        while(!que.empty()){
            cur=que.front();
            que.pop();
            net.mod=(cur.mod*10)%n;
            net.s=cur.s+'0';
            if(net.mod==0){
                cout<<net.s<<endl;
                break;
            }
            if(!vis[net.mod]){
                que.push(net);
                vis[net.mod]=1;
            }
            net.mod=(cur.mod*10+1)%n;
            net.s=cur.s+'1';
            if(net.mod==0){
                cout<<net.s<<endl;
                break;
            }
            if(!vis[net.mod]){
                que.push(net);
                vis[net.mod]=1;
            }
        }
    }
    
}

 

转载于:https://www.cnblogs.com/cangT-Tlan/p/7502231.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值