cout << fixed << setprecision( # )<<#<<endl; //小数;
_____________________________________________________________________________
打九折
试题描述
为了吸收更多的顾客,超市决定在周末开展打折活动,所有商品打九折。某顾客买了X元的食品,请编程算出他要付多少钱?
输入要求
一行,一个数。
Copy
输出要求
一行,一个数。(保留一位小数)
Copy
输入样例 21 输出样例 18.9
_____________________________________________________________________________
方法1:
#include<bits/stdc++.h>
using namespace std;
int main(){
double a,x;
cin>>a;
x=a*0.9;
cout<<fixed<<setprecision(1)<<x;
return 0;
}
方法2:
#include<bits/stdc++.h>
using namespace std;
int main(){
double a;
cin>>a;
cout<<fixed<<setprecision(1)<<a*0.9;
return 0;
}