I - Palindromes
Recently, Nvoenewr learnt palindromes in his class.
A palindrome is a nonnegative integer that is the same when read from left to right and when read from right to left. For example, 0, 1, 2, 11, 99, 232, 666, 998244353353442899 are palindromes, while 10, 23, 233, 1314 are not palindromes.
Now, given a number, Nvoenewr can determine whether it’s a palindrome or not by using loops which his teacher has told him on the class. But he is now interested in another question: What’s the K-th palindrome? It seems that this question is too difficult for him, so now he asks you for help.
Nvoenewr counts the number from small to big, like this: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 11, 22, 33, 44, 55, 66, 77, 88, 99, 101 and so on. So the first palindrome is 0 and the eleventh palindrome is 11 itself.
Nvoenewr may ask you several questions, and the K may be very big.
Input
The first line contains one integer T(T <= 20) —— the number of questions that Nvoenewr will ask you.
Each of the next T lines contains one integer K. You should find the K-th palindrome for Nvoenewr.
Let’s say K is a n-digit number. It’s guaranteed that K >= 1, 1 <= n <= 100000 and the sum of n in all T questions is not greater than 1000000.
Output
Print T lines. The i-th line contains your answer of Nvoenewr’s i-th question.
Sample Input
4
1
10
11
20
Sample Output
0
9
11
101
题解:打表找规律!!!!在int范围内,打表很容易就可以看出规律。s[100010]来保存k,Len表示k的位数。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int T;
char s[100100];
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%s",s);
int len=strlen(s);
if(len==1)//字符串长度为1的时候直接输出s[0]-1
{
printf("%c\n",s[0]-1);
continue;
}
if(len==2&&s[0]=='1'&&s[1]=='0')//字符串长度为2且s[0]=1,s[1]=0的时候直接输出9
{
printf("9\n");
continue;
}
if(s[0]=='1')
{
if(s[1]=='0')//s[0]=1且s[1]=0的时候
{
printf("9");
for(int i=2;i<len;i++)
printf("%c",s[i]);
for(int i=len-2;i>1;i--)
printf("%c",s[i]);
printf("9\n");
}
else//s[0]=1且s[1]!=0的时候
{
for(int i=1;i<len;i++)
printf("%c",s[i]);
for(int i=len-1;i>0;i--)
printf("%c",s[i]);
printf("\n");
}
}
else//s[0]!=1的时候
{
printf("%c",s[0]-1);
for(int i=1;i<len;i++)
printf("%c",s[i]);
for(int i=len-2;i>0;i--)
printf("%c",s[i]);
printf("%c\n",s[0]-1);
}
}
return 0;
}