uva-657 - The die is cast

 The die is cast 

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence $a_1, a_2, \dots, a_k$ in Ssuch that a = a1 and b = ak , and ai and ai+1 are connected for $1 \le i < k$.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy $5 \leŸw,h \le 50$ .

The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4

    题意就是给你一幅图,上面有'.' 'X' '*‘三种符号,’.'是背景, ’*’和‘X’组成骰子,要你找出图中每个骰子的点数,最后按点数升序输出。其中'X'代表骰子点数,而且几个连通(上下左右四个方向才算连通)的X算作同一点。

    思路比较简单,也是找连通块,一个骰子算作一个连通块,还有就是X组成的连通块。统计每个骰子里有多少个X的连通块就得出点数。


#include <iostream>
#include <algorithm>
using namespace std;

char g[50][50];
int w, h;

int dir[4][2] = { {-1,0},{0,1},{1,0},{0,-1}};

void count( int x, int y)   // 点数的深搜,查找X连通块。连通的X算同一点。
{
    g[x][y] = '*';     //将X换成*才不会导致破坏原来骰子的连通性
    int cnt = 1;

    for( int  i = 0; i < 4; i++){
        int nx = x+dir[i][0], ny = y+dir[i][1];
        if( nx < 0 || ny < 0 || nx >= h || ny >= w) continue;
        if( g[nx][ny] == 'X')
             count( nx, ny);

    }

}


int dfs( int x, int y)  //同一块骰子是一个连通块。深搜查找并统计一块骰子的点数
{
    g[x][y] = '.';
    int cnt = 0;  //记录点数
    for( int i = 0; i < 4; i++){                   //只有上下左右四个方向才算连通
        int nx = x+dir[i][0], ny = y+dir[i][1];
        if( nx < 0 || ny < 0 || nx >= h || ny >= w) continue;
        if( g[nx][ny] == '*') cnt += dfs( nx, ny);      //进一步递归
        if( g[nx][ny] == 'X') { cnt++; count( nx, ny); i--;} 
    }

    return cnt;

}

int main()
{
    int ans[30];
    int cases = 1;

    while( cin >> w >> h){
        if( !w && !h) break;
        for( int i = 0; i < h; i++)
            for( int j = 0; j < w; j++)
            cin >> g[i][j];

        int cnt = 0;
        for( int i = 0; i < h; i++)
            for( int j = 0; j < w; j++)
        if( g[i][j] == '*')             //遇到一个骰子深搜一次
            ans[cnt++] = dfs( i, j); 

        sort( ans, ans+cnt);

        cout << "Throw " << cases++ << endl;
        for( int i = 0; i < cnt; i++){
            cout << ans[i];
            if( i < cnt-1) cout << " ";
        }
        cout << endl << endl;
    }
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值