hdu 4920 矩阵循环

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3273    Accepted Submission(s): 1382


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

Sample Input
  
  
1 0 1 2 0 1 2 3 4 5 6 7
 

Sample Output
  
  
0 0 1 2 1
 

Author
Xiaoxu Guo (ftiasch)
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5177  5176  5175  5174  5173 
 


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define maxn 805
typedef long long ll;
int a[maxn][maxn];
int b[maxn][maxn];
int c[maxn][maxn];
int n;

int main()
{
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++){
                scanf("%lld", &a[i][j]);
                a[i][j] %= 3;
            }
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++){
            scanf("%lld", &b[i][j]);
            b[i][j] %= 3;
        }

        memset(c, 0, sizeof(c));
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                for(int k = 1; k <= n; k++)  //注意内层循环顺序,利用cpu cache机制
                c[i][k]=(c[i][k]+a[i][j]*b[j][k]);

        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++){
                printf("%d", c[i][j]%3);
                if(j < n)
                    printf(" ");
                else
                    printf("\n");
            }
        }

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值