poj 1821 dp+单调队列

Fence
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3858 Accepted: 1176

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct. 

Being the team's leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income. 

Write a program that determines the total maximal income obtained by the K workers. 

Input

The input contains: 
Input 

N K 
L1 P1 S1 
L2 P2 S2 
... 
LK PK SK 

Semnification 

N -the number of the planks; K ? the number of the workers 
Li -the maximal number of planks that can be painted by worker i 
Pi -the sum received by worker i for a painted plank 
Si -the plank in front of which sits the worker i 

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4
3 2 2
3 2 3
3 3 5
1 1 7 

Sample Output

17

Hint


#include <iostream>
#include <cstring>
#include <cstdio>
#include <deque>
#include <algorithm>

using namespace std;

#define maxn 16001
#define maxk 101
typedef long long ll;

int n, k;
ll dp[maxn];
struct Data
{
    ll l, p, s;
    bool operator <(const Data&a) const
    {
        return s < a.s;
    }
}a[maxk];

int main()
{
    while(~scanf("%d%d", &n, &k)){
        for(int i = 0; i < k; i++)
            scanf("%I64d%I64d%I64d", &a[i].l, &a[i].p, &a[i].s);
        sort(a, a+k);
        memset(dp, 0, sizeof(dp));


        for(int i = 0; i < k; i++){
            deque<int> que;
            for(int j = max(a[i].s-a[i].l, (ll)0); j < a[i].s; j++){
                while(!que.empty()){
                    int last = que.back();
                    if(dp[last]+a[i].p*(i-last) <= dp[j]+a[i].p*(i-j))
                        que.pop_back();
                    else break;
                }
                que.push_back(j);
            }

            for(int j = a[i].s; j < a[i].s+a[i].l && j <= n; j++){
                while(!que.empty() && que.front() < j-a[i].l) que.pop_front();

                if(!que.empty())
                dp[j] = max(dp[j], dp[que.front()]+a[i].p*(j-que.front()));
            }
        }

        ll ans = 0;
        for(int i = 0; i <= n; i++)
            ans = max(ans, dp[i]);
        printf("%I64d\n", ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值