Fliptile POJ - 3279 状态压缩+dfs

问题:

 

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:有一个M*N的网格,每个单位有两面,一面为白色(用0表示),另一面为黑色(用1表示)。反转一个单位时,它自己连同它的上下左右共5个单位都会发生变化。问若能使这个网格全变为白色朝上,需要怎样反转(输出的矩阵:1表示对对应的位置反转1次)。若不能则输出:“IMPOSSIBLE”。

思路:刚开始用暴力深搜写的写了两边超时,然后想了好久也不知道怎样改进,然后看了别人的题解才算明白点。

(1)由于在同一个位置连续两次反转相当于没有反转,则若要反转必只反转1次.

(2)我们发现,若已经确定第一行的状态,则第二行为了让第一行的所有单位都变成白色,第二层的反转方法就确定了,这样的话第三层的反转也可以从第二层的状态确定下来……直到最后一层。若最后一层在把它上面那层全部变为白色后,它的反转方法能使它自己也变为白色,则这个方法就是一个合理的方法。由此,我们就可以枚举第一层的所有状态来确定整个网格的所有状态了。 

(3)利用二进制枚举第一层的所有反转情况,由此推出这个状态是否可行以及其反转次数,更新最小次数以及对应的ans数组

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[20][20],m,n,minn,p[20][20],book[20][20];
int to[5][2]= {0,0,1,0,0,1,-1,0,0,-1};
int judge(int x,int y)
{
    int c=s[x][y];//注意这里要加上原来的状态
    for(int i=0; i<5; i++)//查询周围四个以及自己的翻转次数
    {
        int dx=x+to[i][0];
        int dy=y+to[i][1];
        if(dx>=0&&dy>=0&&dx<m&&dy<n)
            c+=book[dx][dy];
    }
    return c&1;
}
int dfs()//根据确定的第一行向下递推
{
    for(int i=1; i<m; i++)
        for(int j=0; j<n; j++)
            if(judge(i-1,j))
                book[i][j]=1;
    for(int i=0; i<n; i++)//判断最后一行是否全为空白
        if(judge(m-1,i))
            return -1;
    int ans=0;
    for(int i=0; i<m; i++)
        for(int j=0; j<n; j++)
            ans+=book[i][j];
    return ans;
}
int main()
{
    scanf("%d%d",&m,&n);
    int sum=-1;
    for(int i=0; i<m; i++)
        for(int j=0; j<n; j++)
            scanf("%d",&s[i][j]);
    for(int i=0; i<1<<n; i++)//i表示一个二进制数,用来枚举第1行的各种不同翻法,如0001就是只翻最后一个
    {
        memset(book,0,sizeof(book));
        for(int j=0; j<n; j++)
            book[0][n-j-1]=i>>j&1;//从后往前填,符合字典序从小到大
        int num=dfs();
        if(num>0&&(sum<0||sum>num))
        {
            sum=num;
            memcpy(p,book,sizeof(book));
        }
    }
    if(sum==-1)printf("IMPOSSIBLE\n");
    else
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
                if(j==0)
                    printf("%d",p[i][j]);
                else
                    printf(" %d",p[i][j]);
            printf("\n");
        }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值