LOOPS HDU - 3853 dp求期望值

问题:

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 


The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 


 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 

 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 
 

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000

题意:有一个R*C的网格,每走一次消耗2点能量,现在要从起点 (1,1) 走到 (R , C),有三种走法:第一种原点不动;第二种向下走;第三种:向右走。三种走法的概率之和为1。求走到出口需要能量值的期望值。

思路:dp期望值的入门题,直接套数学期望值的公式即可,代码有详解。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<map>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define ll long long
#define PI acos(-1.0)
#define eps 1e-8
#define mod 1000000007
#define lowbit(x) x&(-x)
#define N 1010
//原点的概率,往右走一步的概率,往下走一步的概率分别用p1,p2,p3表示,
//则期望等于dp[i][j]=dp[i][j]*p1+dp[i][j+1]*p2+dp[i+1][j]*p3+2(2为移动一次的消耗的能量)化简为
//dp[i][j]=(dp[i][j+1]*p2+dp[i+1][j]*p3+2)/(1-p1);
double dp[N][N];
double s[N][N][3];//表示原点,往右走一步,往下走一步
double a,b,c,d;
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        mem(dp,0.0);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                for(int k=0; k<3; k++)
                    scanf("%lf",&s[i][j][k]);//这道题比较简单,不用再去算概率了
        for(int i=n; i>0; i--)
            for(int j=m; j>0; j--)
            {
                a=1.0*s[i][j][0];//原点的概率
                b=1.0*dp[i][j+1]*s[i][j][1];//往右走一步的期望
                c=1.0*dp[i+1][j]*s[i][j][2];//往下走一步的期望
                if(i==n&&j==m)continue;
                if(1.0-a<eps)continue;//这一步如果1.0-a==0,是不能进行下一步的,分母不能为零
                dp[i][j]=(b+c+2.0)/(1.0-a);
            }
        printf("%.3f\n",dp[1][1]);
    }
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值