Happy 2004 HDU - 1452 积性函数+逆元+快速幂

问题:

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29). 

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6. 

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed. 

Output

For each test case, in a separate line, please output the result of S modulo 29. 

Sample Input

1
10000
0

Sample Output

6
10

题意:2004^x的所有正因数的和(S)对29求余;输出结果;

思路:积性函数,当gcd(a,b)=1时s(a*b)=s(a)*s(b);

如果p是素数  s(p^n)=1+p+p^2+...+p^n=(p^(n+1)-1) /(p-1) (1)

2004=2^2 *3 *167     

s(2004^X) ) = (s(2^2X))) *(s(3^X))) * (s(167^X)))

167%29=22;

s(2004^X) ) = (s(2^2X))) *(s(3^X))) * (s(22^X)))

a=s(2^2X)=(2^(2X+1)-1)//根据 (1)

b=s(3^X)= (3^(X+1)-1)/2//根据 (1)

c=s(22^X)= (22^(X+1)-1)/21//根据 (1)

%运算法则 1. (a*b) %p= ( a%p) *(b%p)

%运算法则 2. (a/b) %p= ( a *b^(-1)%p)

2的逆元是15

21的逆元是18

因此

a=(powi(2,2*x+1,29)-1)%29;

b=(powi(3,x+1,29)-1)*15 %29;

c=(powi(22,x+1,29)-1)*18 %29;

ans=(a*b)% 29*c % 29;

代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef __int64 ll;
ll pow(int x,int y)
{
    x=x%29;
    int sum=1;
    while(y>0)
    {
        if(y%2!=0)
            sum=(sum*x)%29;
        x=x*x%29;
        y=y/2;
    }
    return sum%29;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        ll a=(pow(2,2*n+1)-1)%29;
        ll b=(pow(3,n+1)-1)*15%29;
        ll c=(pow(22,n+1)-1)*18%29;
        printf("%I64d\n",a*b%29*c%29);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值