一.题目描述
动态内存分配(new和delete的使用)
Description
输入n个整型数,包含<algorithm>,采用sort函数对其按从小到大顺序排序后输出。
Input
采用cin输入整型数个数n及其对应的n个整数。
Output
输出排序后的数据序列。
二.输入与输出
Sample Input 1
5
5 4 1 3 2
Sample Output 1
1 2 3 4 5
三.代码
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int n;
cin>>n;
int *s=new int[n];
for(int i=0;i<n;i++){
cin>>s[i];
}
sort(s,s+n);
for(int i=0;i<n;i++){
cout<<s[i]<<" ";
}
delete []s;
return 0;
}