ACM集训日结·动态规划入门

一. 01背包

1. 基本逻辑

01背包问题是动态规划里最简单的一种问题了,问背包容量为M,给出N个物品,分别的重量和价值,问该背包最大能装多少价值的物品。原理很简单,每次选择都有两种状态:装或者不装,我们便可以推出本级最大价值和上一级的关系 即 dp[ i ][ j ] = max(dp[ i-1 ][ j ] , dp[ i-1 ][ j-w[ i ] ] + v[ i ]),这在代码中可以用二维数组来实现。

2. 代码实现
for(int i=0;i<=N;i++)
	for(int j=0;j<=M;j++){
		if(w[i]<=j)          //能装的下第i个
			dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i];//不装第i个和装第i个
		else                 //装不下第i个
			dp[i][j]=dp[i-1][j];
			}
3. 代码优化(滚动数组)

不难发现,这样子开二维数组有点浪费空间,想到只用一维数组是否也能实现。

for(int i=0;i<=N;i++)
	for(int j=0;j<=M;j++)
			dp[j]=max(dp[j],dp[j-w[i]]+v[i];//不装第i个和装第i个

这样是否能实现呢?
认真推导一下可以发现,是有问题的,因为物品会被重复使用,所以使用一维数组时不应该破坏j小的数据,于是改为以下写法。

for(int i=0;i<=N;i++)
	for(int j=M;j>=0;j--)
			dp[j]=max(dp[j],dp[j-w[i]]+v[i];//不装第i个和装第i个

很快会发现这个代码也是不妥的,当j比w[i]小的时候,显然会访问到下标小于0的数组,但是我们发现,当j<w[i]的时候,数据恰好和上一轮的肯定一样,不需要更新,于是代码又变成了下面这样。

for(int i=0;i<=N;i++)
	for(int j=M;j>=w[i];j--)
			dp[j]=max(dp[j],dp[j-w[i]]+v[i];//不装第i个和装第i个

二. 完全背包

1. 基本逻辑

类似于01背包,完全背包也是要求最大能装多少,不过能装的物品数量是无限的

2. 代码实现
for(int i=0;i<=N;i++)
	for(int j=0;j<=M;j++)
		for(int k=0;k*w[i]<=j;k++)
			dp[i][j]=max(dp[i-1][j],dp[i-1][j-k*w[i]]+v[i]);
3. 代码优化(时间优化)
for(int i=0;i<=N;i++)
	for(int j=0;j<=M;j++){
		dp[i][j]=dp[i-1][j];
		if (j>=v[i]) 
				dp[i][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);
				}
4. 代码优化(滚动数组)
for(int i=0;i<=N;i++)
	for(int j=0;j<=M;j++)
			dp[j]=max(dp[j],dp[j-w[i]]+v[i]);

三. 实战练习

1. 01背包练习题

<1> 纯01背包问题
Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

问题分析

题意就是,一个人要拿珠宝,给出 N N N M M M,分别代表珠宝的数量和人的可承载重量,接下来的 N N N行就是每种珠宝的 W i W_i Wi D i D_i Di(重量和价值)。很显然这是一道很经典的01背包问题,很容易就能实现,01背包上面已经分析过了,这就不加以分析。

代码实现
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
int dp[13000];
struct charm{   //也可以用两个数组代替
	int w; //weight
	int v; //value
}c[4000];
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++)
		cin>>c[i].w>>c[i].v;
	c[0].w=0;
	c[0].v=0;
	for(int i=1;i<=n;i++)   //dp方案
		for(int j=m;j>=c[i].w;j--)
			dp[j]=max(dp[j-c[i].w]+c[i].v,dp[j]);
	cout<<dp[m];
	return 0;
}

2. 完全背包练习题

<1> 存钱罐最少钱问题
Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

问题分析

经典的完全背包问题变成同容量装的最少值,则需要把完全背包的max改成min,并且初始化时应用无穷大替代0.

代码实现
#include<cstdio>
#include<iostream>
#include<algorithm>
#define inf 0x7ffffff  //无穷大 作为初始化的值
using namespace std;
int t,n,e/*empty*/,f/*full*/;
int dp[10000];
int w[520];
int v[520]; 
int main()
{
	cin>>t;
	while(t--){
		cin>>e>>f;
		int pig=f-e;
		for(int i=1;i<=pig;i++)
			dp[i]=inf;
		dp[0]=0;
		cin>>n;
		for(int i=1;i<=n;i++){
			cin>>v[i]>>w[i];
		}
		for(int i=0;i<=n;i++){
			for(int j=0;j<=pig;j++){
				if(j>=w[i])
					dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
			}
		}
		if(dp[pig]!=inf)//刚好分配完则数字肯定被更新
			cout<<"The minimum amount of money in the piggy-bank is "<<dp[pig]<<".\n";
		else
			cout<<"This is impossible.\n";
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值