POJ2488 A Knight's Journey(深搜)

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44467 Accepted: 15107

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

void dfs(int i,int j,int tmp);
void print();

int dx[8]={-2,-2,-1,-1,1,1,2,2};
int dy[8]={-1,1,-2,2,-2,2,-1,1};//注意访问顺序,输出按字典序输出;

int visit[30][30];
char ansx[30];
int ansy[30];

int p,q;
int flag;

int main()
{
    int n,cou=1;
    cin>>n;
    while(n--)
    {
        cin>>p>>q;
        flag=0;

        memset(visit,0,sizeof(visit));
        memset(ansx,0,sizeof(ansx));
        memset(ansy,0,sizeof(ansy));

        ansx[0]='A';
        ansy[0]=1;
        visit[1][1]=1;

        printf("Scenario #%d:\n",cou++);
        if(q*p==1)
            printf("A1\n");
        else
        {
             dfs(1,1,1);
             if(flag==0)
                printf("impossible\n");
        }
        printf("\n");
    }
    return 0;
}
void dfs(int i,int j,int tmp)
{
     if(tmp==p*q)
    {
        print();
        flag=1;
        return;
    }
    int nx,ny;
    for(int s=0;s<8;s++)
    {
        nx=dx[s]+i;
        ny=dy[s]+j;
        if(nx>=1&&nx<=q&&ny>=1&&ny<=p&&!visit[nx][ny])
        {
            visit[nx][ny]=1;
            ansx[tmp]=nx+'A'-1;
            ansy[tmp]=ny;
            dfs(nx,ny,tmp+1);
            if(flag==1)
                return;//如果tmp=p*q,flag=1;函数结束,不再执行下面的内容;
            visit[nx][ny]=0;//将访问的节点值改回原值;
        }
    }
    return;
}
void print()
{
    int i=1;
    for(i=0;i<p*q;i++)
    {
        printf("%c%d",ansx[i],ansy[i]);
    }
    printf("\n");
    return;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值