POJ 3617 Best Cow Line (贪心)

                              Best Cow Line
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.
Sample Input

6
A
C
D
B
C
B
Sample Output

ABCBCD
解题思路

给一个字符串  在头或尾取字符排列成字典序最小的字符串  测例中ACDBCB 重排之后不是ABCDBC  而是ABCBCD  

比较首尾字符大小输出小的 若相等则比较下一组

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;
char q[2010];
int solve(int head,int tail)
{
    if(head>=tail)      return 0;               //若余下的全部相等不妨输出前面的  注意是>=
    if(q[head]<q[tail]) return 0;
    if(q[head]>q[tail]) return 1;
    return solve(head+1,tail-1);                //若相等 则比较下一组
}
int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    int n,h,t,k=1;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf(" %c",&q[i]);                    //" %c"  %c前加空格可以吸收空格回车
    }
    h=0,t=n-1;                                 //初始化
    while(h<=t){                               //'='是为了输出剩余的最后的字符
        if(solve(h,t)) printf("%c",q[t--]);
        else           printf("%c",q[h++]);
        if(!(k++%80))  printf("\n");           //题中要求满80个换行
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值