题目 1096: Minesweeper

题目

Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can’t remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a ``*‘’ character. If we represent the same field by the hint numbers described above, we end up with the field on the right: … … .… … 100 2210 110 1110

输入
The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n, m$ \le$100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by .'' and mine squares by *,‘’ both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.

输出
For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.‘’ characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.

样例输入
4 4


.


3 5
**…

.*…
0 0

样例输出
Field #1:
100
2210
1
10
1110

Field #2:
**100
33200
1*100

解题思路

本题就是排雷问题,每一个点的四周共有多少个雷,则输出多少个雷。首先,读入数据到hash散列,该散列中,对应位置为0,则代表该位置处没有雷,为1,则是雷所在的位置;之后遍历每一个点进行输出,如果是雷,则输出‘*’,如果无雷,则判断周围八点雷的数目并输出。

代码

#include<stdio.h>
int main()
{
    int n,m,i,j,num,k=1;
    char t;
    scanf("%d %d\n",&n,&m);
	while (n!=0 && m!=0){
	    int boom[n+2][m+2];//hash,存放炸弹的坐标,有炸弹的地方就是1
	    for (i=0;i<(n+2);i++)//初始化
	        for (j=0;j<(m+2);j++)
	            boom[i][j] = 0;
	    for (i=1;i<=n;i++)//读入地雷位置
	    {
	        for (j=1;j<=m;j++)
	        {
	            t = getchar();
	            if (t=='*')
	                boom[i][j] = 1;
	        }
	        getchar();//读取换行符
	    }
	    printf("Field #%d:\n",k++);
	    for (i=1;i<=n;i++)
	    {
	        for (j=1;j<=m;j++)
	        {
	            num = 0;
	            if (boom[i][j]==1)
	                printf("*");
	            else
	            {
	                num+=(boom[i-1][j]+boom[i+1][j]+boom[i][j-1]+boom[i][j+1]);
	                num+=(boom[i-1][j+1]+boom[i+1][j+1]+boom[i-1][j-1]+boom[i+1][j-1]);
	                printf("%d",num);
	            }
	        }
	        printf("\n");
	    }
	    printf("\n");
	    scanf("%d %d\n",&n,&m);//读取下一组
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值