PAT甲级1050:String Subtraction (20)

题目

Given two strings S1 and S2, S = S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:
For each test case, print S1−S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

解题思路

首先读入第一行字符串记为a(注意字符串可能含有空格,因此需要用fgets);再按照char依次读入第二行的字符,以int类型的hash散列存储读入的字符(读入的字符对应的ASCII作为hash散列的下标,读入的标为1,表示需要删去)。最后遍历a,如果当前a中元素对应的hash[a[i]]为0,则输出;反之,删去,即不输出。

易错点

虽然题目中说“ It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string”,但是最后一行字符的末尾是没有换行符的,不要以换行符判断字符串是否结束。

代码

#include<bits/stdc++.h>
using namespace std;
int Hash[129];//标记该字符是否需要删去(0不删,1删去)

int main(){
    char a[10002],temp;
    fgets(a,10002,stdin);
    int lena = strlen(a);
    a[--lena] = '\0';//把行末读入的'\n'删去
    while (scanf("%c",&temp)!=EOF){
        Hash[temp] = 1;}
    for (int i=0;i<lena;i++)
        if (Hash[a[i]]==0)
            printf("%c",a[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值