【codevs 3187】队列练习3

题目描述 Description
比起第一题,本题加了另外一个操作,访问队头元素(编号3,保证访问队头元素时或出队时队不为空),现在给出这N此操作,输出结果。

输入描述 Input Description
N
N次操作(1入队 2出队 3访问队头)

输出描述 Output Description
K行(K为输入中询问的个数)每次的结果

样例输入 Sample Input
6
1 7
3
2
1 9
1 7
3

样例输出 Sample Output
7
9

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=100000+10;
int a[maxn],k[maxn];
int n,head,tail;
void push(int s)
{
    tail++;
    k[tail]=s;
}
void pop()
{
    head++;
}
int main()
{
    scanf("%d",&n);
    int r;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        if(a[i]==1)
        {
            scanf("%d",&r);
            push(r);
        }
        else if(a[i]==2)
        {
            pop();
        }
        else if(a[i]==3)
        {
            cout<<k[head+1]<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值