【codevs 1535】封锁阳光大学

题目描述 Description
曹是一只爱刷街的老曹,暑假期间,他每天都欢快地在阳光大学的校园里刷街。河蟹看到欢快的曹,感到不爽。河蟹决定封锁阳光大学,不让曹刷街。

阳光大学的校园是一张由N个点构成的无向图,N个点之间由M条道路连接。每只河蟹可以对一个点进行封锁,当某个点被封锁后,与这个点相连的道路就被封锁了,曹就无法在与这些道路上刷街了。非常悲剧的一点是,河蟹是一种不和谐的生物,当两只河蟹封锁了相邻的两个点时,他们会发生冲突。

询问:最少需要多少只河蟹,可以封锁所有道路并且不发生冲突。

输入描述 Input Description
第一行:两个整数N,M

接下来M行:每行两个整数A,B,表示点A到点B之间有道路相连。

输出描述 Output Description
仅一行:如果河蟹无法封锁所有道路,则输出“Impossible”,否则输出一个整数,表示最少需要多少只河蟹。

样例输入 Sample Input
【输入样例1】

3 3

1 2

1 3

2 3

【输入样例2】

3 2

1 2

2 3

样例输出 Sample Output
【输出样例1】

Impossible

【输出样例2】

1

数据范围及提示 Data Size & Hint
【数据规模】

1<=N<=10000,1<=M<=100000,任意两点之间最多有一条道路。

大致是一张无向图,对点进行染色。每条边有且只有一个端点被染色,即相邻点不能染色。求进行染色的端点数。
注意图可能不连通。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=100000+10;
int first[maxn<<1],nxt[maxn<<1],tot=0;
int color[maxn];//定义1、2两种颜色 
int n,m,ans;
struct edge
{
    int f,t;
}l[maxn<<1];
void build(int f,int t)
{
    l[++tot]=(edge){f,t};
    nxt[tot]=first[f];
    first[f]=tot;
    return;
}
int colour(int s)
{
    queue<int>q;
    while(!q.empty()) q.pop();
    int cnt1=0,cnt2=0;
    q.push(s);
    color[s]=1;
    while(!q.empty())
    {
        int f=q.front();
        q.pop();
        if(color[f]==1) cnt1++;
        else cnt2++;//不同颜色的点的数量 
        for(int i=first[f];i;i=nxt[i])
        {
            int w=l[i].t;
            if(!color[w])//下一个点尚未染色 
            {
                q.push(w);
                color[w]=3-color[f];
            }
            else if(color[w]==color[f]) return -1;//判断是否冲突 
        }
    }
    return ans+=min(cnt1,cnt2);//每个联通分量取最小值 
}
int main()
{
    int f,t;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&f,&t);
        build(f,t);
        build(t,f);//双向边 
    }
    for(int i=1;i<=n;i++)
    {
        if(!color[i])
        {
            if(colour(i)==-1)
            {
                puts("Impossible\n");
                return 0;
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值