hdu 2858 ac自动机 +状态压缩dp

Liyuan lives in a old apartment. One day, he suddenly found that there was a wireless network in the building. Liyuan did not know the password of the network, but he got some important information from his neighbor. He knew the password consists only of lowercase letters ‘a’-‘z’, and he knew the length of the password. Furthermore, he got a magic word set, and his neighbor told him that the password included at least k words of the magic word set (the k words in the password possibly overlapping).

For instance, say that you know that the password is 3 characters long, and the magic word set includes ‘she’ and ‘he’. Then the possible password is only ‘she’.

Liyuan wants to know whether the information is enough to reduce the number of possible passwords. To answer this, please help him write a program that determines the number of possible passwords.
Input
There will be several data sets. Each data set will begin with a line with three integers n m k. n is the length of the password (1<=n<=25), m is the number of the words in the magic word set(0<=m<=10), and the number k denotes that the password included at least k words of the magic set. This is followed by m lines, each containing a word of the magic set, each word consists of between 1 and 10 lowercase letters ‘a’-‘z’. End of input will be marked by a line with n=0 m=0 k=0, which should not be processed.
Output
For each test case, please output the number of possible passwords MOD 20090717.
Sample Input
10 2 2
hello
world
4 1 1
icpc
10 0 0
0 0 0
Sample Output
2
1
14195065

题意: 给你n m k 给你m个单词 让你求有多少种长度为n的串,使得m个单词中含有k个在里面
m的数量较少 用ac自动机+状态压缩dp

dp[i][j][S] 分别是 构造的串的第i个字符,j是指在字典树上的哪个点,那么next[j][t] 代表j可以到达t,所以j的数量累加到t上。同时更新状态S|=t[next][j].end;(单词的末尾点)


#include <bits/stdc++.h>
using namespace std;
#define M 26*10+5
const int SIGMA_SIZE = 26;

typedef long long ll;
const ll MOD = 20090717;
struct AC  
{  
    ll end[M];
    ll dp[30][M][(1<<10)+2];
    int ch[M][26];  
    int val[M];  
    int height[M];  
    int fail[M],last[M];  
    int sz;  
    void clear(){memset(ch[0],0,sizeof(ch[0]));sz=0;}  
    int idx(char x){return x-'a';}  
    int insert(char *s,int id)  
    {  
        int u=0;  
        int n=strlen(s);  
        for(int i=0;i<n;i++)  
        {  
            int c=idx(s[i]);  
            if(!ch[u][c])  
            {              
                ch[u][c]=++sz;  
                end[sz]=0;
                memset(ch[sz],0,sizeof(ch[sz]));  
                height[sz]=height[u]+1;  
                val[sz]=0;  

            }  
            u=ch[u][c];  
        }  
        val[u]++;
        end[u]|=(1<<id);  
        return u;  
    }  
    void getfail()  
    {  
        queue<int> q;  
        fail[0]=0;  
        int u=0;  
        for(int i=0;i<SIGMA_SIZE;i++)  
        {  
            u=ch[0][i];  
            if(u){q.push(u);fail[u]=0;last[u]=0;}  
        }  
        while(!q.empty())  
        {  
            int r=q.front();q.pop();  
            end[r]|=end[fail[r]];
            for(int i=0;i<SIGMA_SIZE;i++)  
            {  
                u=ch[r][i];  
                if(!u){ch[r][i]=ch[fail[r]][i];continue;}  
                q.push(u);  
                int v=fail[r];  
                while(v&&!ch[v][i])v=fail[v];  
                fail[u]=ch[v][i];  
                last[u]=val[fail[u]]?fail[u]:last[fail[u]];  
            }  
        }  
    }  
    ll solve(int n,int m,int k)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=sz;j++)
            {
                for(int S=0;S<(1<<m);S++)
                    dp[i][j][S]=0;
            }
        }
        dp[0][0][0]=1;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<=sz;j++)
            {
                for(int S=0;S<(1<<m);S++)
                {
                    if(dp[i][j][S]<=0) continue;
                    for(int tt=0;tt<26;tt++)
                    {
                        int ni=i+1,nj=ch[j][tt];
                        int nS=S|end[nj];
                        dp[ni][nj][nS]=(dp[ni][nj][nS]+dp[i][j][S])%MOD;                
                    }
                }
            }
        }

        ll res=0;
        for(int S=0;S<(1<<m);S++)
        {
            int cnt=0;
            for(int i=0;i<m;i++)
                if(S&(1<<i)) ++cnt;
            if(cnt>=k)
            {
                for(int i=0;i<=sz;i++)
                    res=(res+dp[n][i][S])%MOD;
            }
        }
        return res;
    }
}tree;  



char s[30];


int main()
{

        int n,m,k;
        while(scanf("%d%d%d",&n,&m,&k),n||m||k)
        {
        tree.clear();
        for(int i=0;i<m;i++)
        scanf(" %s",s),tree.insert(s,i);

        tree.getfail();
        printf("%lld\n",tree.solve(n,m,k) );
        }
        return 0;
}
数据中心机房是现代信息技术的核心设施,它承载着企业的重要数据和服务,因此,其基础设计与规划至关重要。在制定这样的方案时,需要考虑的因素繁多,包括但不限于以下几点: 1. **容量规划**:必须根据业务需求预测未来几年的数据处理和存储需求,合理规划机房的规模和设备容量。这涉及到服务器的数量、存储设备的容量以及网络带宽的需求等。 2. **电力供应**:数据中心是能源消耗大户,因此电力供应设计是关键。要考虑不间断电源(UPS)、备用发电机的容量,以及高效节能的电力分配系统,确保电力的稳定供应并降低能耗。 3. **冷却系统**:由于设备密集运行,散热问题不容忽视。合理的空调布局和冷却系统设计可以有效控制机房温度,避免设备过热引发故障。 4. **物理安全**:包括防火、防盗、防震、防潮等措施。需要设计防火分区、安装烟雾探测和自动灭火系统,设置访问控制系统,确保只有授权人员能进入。 5. **网络架构**:规划高速、稳定、冗余的网络架构,考虑使用光纤、以太网等技术,构建层次化网络,保证数据传输的高效性和安全性。 6. **运维管理**:设计易于管理和维护的IT基础设施,例如模块化设计便于扩展,集中监控系统可以实时查看设备状态,及时发现并解决问题。 7. **绿色数据中心**:随着环保意识的提升,绿色数据中心成为趋势。采用节能设备,利用自然冷源,以及优化能源管理策略,实现低能耗和低碳排放。 8. **灾难恢复**:考虑备份和恢复策略,建立异地灾备中心,确保在主数据中心发生故障时,业务能够快速恢复。 9. **法规遵从**:需遵循国家和地区的相关法律法规,如信息安全、数据保护和环境保护等,确保数据中心的合法运营。 10. **扩展性**:设计时应考虑到未来的业务发展和技术进步,保证机房有充足的扩展空间和升级能力。 技术创新在数据中心机房基础设计及规划方案中扮演了重要角色。例如,采用虚拟化技术可以提高硬件资源利用率,软件定义网络(SDN)提供更灵活的网络管理,人工智能和机器学习则有助于优化能源管理和故障预测。 总结来说,一个完整且高效的数据中心机房设计及规划方案,不仅需要满足当前的技术需求和业务目标,还需要具备前瞻性和可持续性,以适应快速变化的IT环境和未来可能的技术革新。同时,也要注重经济效益,平衡投资成本与长期运营成本,实现数据中心的高效、安全和绿色运行。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值