hdu 6215 链表

Beerus needs to sort an array of NN integers. Algorithms are not Beerus’s strength. Destruction is what he excels. He can destroy all unsorted numbers in the array simultaneously. A number A[i]A[i] of the array is sorted if it satisfies the following requirements.
1. A[i]A[i] is the first element of the array, or it is no smaller than the left one A[i−1]A[i−1].
2. A[i]A[i] is the last element of the array, or it is no bigger than the right one A[i+1]A[i+1].
In [1,4,5,2,3][1,4,5,2,3], for instance, the element 55 and the element 22 would be destoryed by Beerus. The array would become [1,4,3][1,4,3]. If the new array were still unsorted, Beerus would do it again.
Help Beerus predict the final array.
Input
The first line of input contains an integer T (1≤T≤10)T (1≤T≤10) which is the total number of test cases.
For each test case, the first line provides the size of the inital array which would be positive and no bigger than 100000100000.
The second line describes the array with NN positive integers A[1],A[2],⋯,A[N]A[1],A[2],⋯,A[N] where each integer A[i]A[i] satisfies 1≤A[i]≤1000001≤A[i]≤100000.
Output
For eact test case output two lines.
The first line contains an integer MM which is the size of the final array.
The second line contains MM integers describing the final array.
If the final array is empty, MM should be 00 and the second line should be an empty line.
Sample Input
5
5
1 2 3 4 5
5
5 4 3 2 1
5
1 2 3 2 1
5
1 3 5 4 2
5
2 4 1 3 5
Sample Output
5
1 2 3 4 5
0

2
1 2
2
1 3
3
2 3 5

。。很久都没看懂题意,原来以为是不满足的两个删去,原来是每一层只要是不满足 a[i]<=a[i+1]的都要删去。醉了,醉了
暴力枚举链表就行,放进一个队列里面,每次删去后,把前继进队重新判。。。

#include <bits/stdc++.h>

using namespace std;
const int N = 1e5+10;
int last[N],nxt[N],que[N],a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        a[0]=0;
        nxt[0]=1;
        last[n+1]=n;
        int top=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            last[i]=i-1;
            nxt[i]=i+1;
            que[top++]=i;
        }
        int ans=n;
        int flag=1;
        while(flag)
        {
            flag=0;
            int now=0;
            int s=0;
            while(now<top)
            {
                int i=que[now];
                int ff=0;
                while(nxt[i]<=n)
                {
                    if(a[i]>a[nxt[i]]) ff++,flag=1,i=nxt[i];
                    else break;
                }
                if(ff) ans-=(ff+1);
                if(ff)
                {
                    nxt[last[que[now]]]=nxt[i];
                    last[nxt[i]]=last[que[now]];
                    que[s++]=last[que[now]];
                }
                while(que[now]<=i&&now<top) now++;
            }
            top=s;
        }
        printf("%d\n",ans );
        int now=0;
        while(now<=n)
        {
            if(now!=0) printf("%d ",a[now] );
            now=nxt[now];
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值