NEU 1642: Laptop Battery

1642: Laptop Battery

时间限制: 1 Sec   内存限制: 128 MB

题目描述

 Nowadays,nearly everyone of ACMers has at least one laptop.

However,when you face with the situation where power is unavailable,you have to relay on the battery of your laptop.Yet,some UI(User Interface) of the battery software is so ugly that you cannot bear with it.

After all,you are a programmer,so you have made up your mind to design a battery software of your own.Thus,you wont argue about the UI.At the end of the day,you finally come up with a design,which looks like this:

++++++++++++

+~~~~~~~~~~+-|

+~~~~~~~~~~+-|

++++++++++++

(when the battery is empty.)

++++++++++++

+======~~~~+-|

+======~~~~+-|

++++++++++++

(when the batter is %60 full.)

输入

 There are several test cases.Each test case contains a line,which describe the current battery status in the form of “%T”(0<=T<=100,T is a multiply of 10).

输出

 For every test case,output 4 lines as described above to show the status of battery.

样例输入

样例输出

提示

来源



CODE:

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int T;
    char c;
    while(c=getchar()&&scanf("%d",&T)!=EOF){
        cout<<"++++++++++++"<<endl;
        for(int j=0;j<2;j++){
            cout<<'+';
            for(int i=0;i<T/10;i++)
                cout<<'=';
            for(int i=T/10;i<10;i++)
                cout<<'~';
            cout<<"+-|"<<endl;
        }
        cout<<"++++++++++++"<<endl;
        getchar();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值