poj 1679__The Unique MST(次小生成树,kruskal)

链接:The Unique MST

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24157 Accepted: 8588

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意:给出一个图,问其最小生成树(MST)是否唯一,一道次小生成树的入门题。

思路:首先遍历求出MST的所有边及权值sum(kruskal比较方便),然后每次删除求出的MST中一条边,对操作完的图进行求MST,如果长度与sum相同,即说明MST不唯一,每次求完MST记得还原删除的边。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAX 0x3f3f3f3f
#define N 10005

int f[N], t, n, m, mst;

struct node {
    int x, y;
    int k;
} edge[N];

int _find(int x)
{
    return f[x] = f[x] == x ? x : _find(f[x]);
}
bool cmp(node a, node b)
{
    return a.k < b.k;
}

void makeset()  //初始化父亲节点
{
    for(int i = 0; i <= n; i++)
        f[i] = i;
}
int Kruskal()
{
    int path[N], cnt = 0;
    makeset();
    for(int i = 0; i < m; i++) {    //第一次求最小生成树
        int u = _find(edge[i].x);
        int v = _find(edge[i].y);
        if(u != v) {
            f[u] = v;
            path[cnt++] = i;
            mst += edge[i].k;

        }
    }
    for(int i = 0; i < cnt; i++) {
        makeset();
        int ans = 0, count = 0;
        for(int j = 0; j < m; j++) {
            if(j == path[i])    //模拟删边操作
                continue;
            int u = _find(edge[j].x);
            int v = _find(edge[j].y);
            if(u != v) {
                f[u] = v;
                ans += edge[j].k;
                count++;
            }
        }
        if(ans == mst && count == n - 1) {
            return 0;
        }
    }
    return 1;
}
int main()
{
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < m; i++) { //输入边的两个顶点及权值
            scanf("%d%d%d", &edge[i].x, &edge[i].y, &edge[i].k);
        }
        mst = 0;
        sort(edge, edge + m, cmp);
        if(Kruskal()) {
            printf("%d\n", mst);
        } else {
            printf("Not Unique!\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值