POJ 3667 Hotel

原题戳


Time Limit: 3000MS
Memory Limit: 65536K


Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.


Input

  • Line 1:
    Two space-separated integers: N and M
  • Lines 2..M+1:
    Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

  • Lines 1…..:
    For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

题意:
1 a:询问是不是有连续长度为a的空房间,返回最左边端点
2 a b:将[a,a+b-1]的房间清空


思路:
用线段树搞
记录区间中最长的连续空房间
因为要记录最长的连续空房间
所以要用到区间合并,即需要对左右儿子的区间进行合并

这道题中线段树的基本操作具体意义:
查询操作:找一段长度为W的没有被覆盖的最左的区间
更新操作:将某段连续的区域清空

代码如下:

#include<cstdio>    
#include<cstring>   
#include<algorithm>    
#define lson l,m,rt<<1    
#define rson m+1,r,r<<1|1    
using namespace std;

const int maxn=55555;    
int lsum[maxn<<2] ,rsum[maxn<<2],msum[maxn<<2];    
int cover[maxn<<2];    

void PushDown(int rt,int m) 
{    
    if(cover[rt]!=-1) 
    {    
        cover[rt<<1]=cover[rt<<1|1]=cover[rt];     
        msum[rt<<1]=lsum[rt<<1]=rsum[rt<<1]=cover[rt]?0:m-(m>>1);/*左右端区间也要更新*/   
        msum[rt<<1|1]=lsum[rt<<1|1]=rsum[rt<<1|1]=cover[rt]?0:(m>>1);/*左右端区间也要更新*/   
        cover[rt]=-1;    
    }    
}

void PushUp(int rt,int m) 
{    
    lsum[rt]=lsum[rt<<1];/*区间合并步骤1*/
    rsum[rt]=rsum[rt<<1|1];/*区间合并步骤1*/
    if(lsum[rt]==m-(m>>1)) 
        lsum[rt] += lsum[rt<<1|1];/*区间合并步骤2*/  
    if(rsum[rt]==(m>>1)) 
        rsum[rt] += rsum[rt<<1];/*区间合并步骤2*/  
    msum[rt]=max(lsum[rt<<1|1]+rsum[rt<<1],max(msum[rt<<1],msum[rt<<1|1]));/*总区间*/
}

void build(int l,int r,int rt)
{    
    msum[rt]=lsum[rt]=rsum[rt]=r-l+1;/*左右端区间也要更新*/  
    cover[rt]=-1;    
    if(l==r) 
        return ;    
    int m=(l+r)>>1;    
    build(lson);
    build(rson);
}

void update(int L,int R,int c,int l,int r,int rt) 
{    
    if (L<=l && r<=R) 
    {    
        msum[rt]=lsum[rt]=rsum[rt]=c?0:r-l+1;/*左右端区间也要更新*/   
        cover[rt]=c;
        return;   
    }    
    PushDown(rt,r-l+1);    
    int m =(l+r)>>1;    
    if(L<=m) 
        update(L,R,c,lson);    
    if(m<R) 
        update(L,R,c,rson);    
    PushUp(rt,r-l+1);    
}    

int query(int w,int l,int r,int rt) 
{    
    if(l==r) 
        return l;    
    PushDown(rt,r-l+1);    
    int m=(l+r)>>1;    
    if(msum[rt<<1]>=w) 
        return query(w,lson);    
    else if(rsum[rt<<1]+lsum[rt<<1|1]>=w) 
        return m-rsum[rt<<1]+1;/*左子右+右子左=中间连续部分*/  
    return query(w,rson);
}

int main() 
{    
    int n,m;    
    scanf("%d%d",&n,&m);    
    build(1,n,1);    
    while(m--) 
    {    
        int op,a,b;    
        scanf("%d",&op);    
        if(op==1) 
        {    
            scanf("%d",&a);    
            if(msum[1]<a) 
                puts("0");    
            else 
            {    
                int p=query(a,1,n,1);    
                printf("%d\n",p);   
                update(p,p+a-1,1,1,n,1);    
            }
        } 
        else 
        {    
            scanf("%d%d",&a,&b);    
            update(a,a+b-1,0,1,n,1);    
        }
    }
    return 0;    
}

蛤蛤 是不是感觉妈妈再也不用担心我的线段树区间合并啦~
不客气!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
使用 JavaScript 编写的记忆游戏(附源代码)   项目:JavaScript 记忆游戏(附源代码) 记忆检查游戏是一个使用 HTML5、CSS 和 JavaScript 开发的简单项目。这个游戏是关于测试你的短期 记忆技能。玩这个游戏 时,一系列图像会出现在一个盒子形状的区域中 。玩家必须找到两个相同的图像并单击它们以使它们消失。 如何运行游戏? 记忆游戏项目仅包含 HTML、CSS 和 JavaScript。谈到此游戏的功能,用户必须单击两个相同的图像才能使它们消失。 点击卡片或按下键盘键,通过 2 乘 2 旋转来重建鸟儿对,并发现隐藏在下面的图像! 如果翻开的牌面相同(一对),您就赢了,并且该对牌将从游戏中消失! 否则,卡片会自动翻面朝下,您需要重新尝试! 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox, 以获得更好、更优化的游戏体验。要玩游戏,首先,通过单击 memorygame-index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值