POJ 3278


Catch That Cow
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


提交了好多次,一直runtime error,起初以为是数组开小了,但并不是,而是在判断的时候,先判断的是否被标记过,后判断的是否数组越界,前面的book数组此时有可能越界了,但是无法判断出来,导致数组溢出,一直runtime error


submit



#include<iostream>
#include<cmath>
#include<algorithm>
#include<stack>
#include<cstring>
#include<queue>
using namespace std;


struct node {
    int x;
    int step;
};

int n, k;
queue<node> road;
int d[2] = {-1, 1};
int book[100001];
int bfs()
{
    memset(book, 0, sizeof(book));
    while(!road.empty())
        road.pop();
    
    node now, next;
    now.x = n;
    now.step = 0;
    book[now.x] = 1;
    road.push(now);
    while(!road.empty()) {
        now = road.front();
        road.pop();
        int i;
        for(i=0; i<3; ++i) {
            if(i==2)
                next.x = now.x * 2;
            else
                next.x = now.x + d[i];
            next.step = now.step + 1;
            if(next.x >=0 && next.x <=100000 && !book[next.x]) {
                if(next.x == k)
                    return next.step;
                road.push(next);
                book[next.x] = 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d", &n, &k)) {
        int time;
        if(n == k) {
            printf("0\n");
            continue;
        }
        time = bfs();
        printf("%d\n", time);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值