The Suspects 解决多棵树合并成一棵树的问题

12 篇文章 0 订阅
The Suspects
Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%lld & %llu

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
 
    
n这个学校的总人数,m是这个学校的社团个数,然后m行,每一行第一个数是这个社团的总人数,后面跟着m个数,代表这个社团的学生,数字代表学生的编号,每一个社团只要有一个人是被怀疑感染了非典,这个社团的所有的人都将被视为可能会被感染者,设定学生编号为0的学生为怀疑感染了非典的人,然后编号为0的学生参加的所有的社团的学生都将被视为可能感染者,结果是让你求可能感染的学生
其实就是给你多棵树,让你把符合条件的树合并到一棵树上
AC代码:
 
    
#include<iostream>  
#include<cstdio>
#include<cstring>  
#include<string>      
#include<queue>      
#include<algorithm>      
#include<map>      
#include<iomanip>      
#define inf 0x3f3f3f3f      
#define maxn 30001
#define maxm 10001    
using namespace std;    
int n,m;
int f[maxn];
int getf(int i)
{
	if(i==f[i])
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}

int merge(int a, int b)
{
	int i=getf(a);
	int j=getf(b); 
	if(i==j)
		return 0;
	else
	{
		if(i==0)//如果已经知道他的根节点为0 ,关键代码,需要改变节点的祖先的指向 
			f[j]=i;
		else f[i]=j;
		return 1;
	}
}

int main()
{
	int k,temp1,temp2,cnt;
	while(~scanf("%d%d",&n,&m) && n) {
		cnt=0;
		for(int i=0;i<n;++i)
			f[i]=i;
		for(int i=0;i<m;++i) {
			scanf("%d%d",&k,&temp1);//先默认每个社团的第一个为该棵树的根节点 
			for(int j=1;j<k;++j) {
				scanf("%d",&temp2);
				if(temp2==0) {//当出现0后,所有节点的祖先都变为0,以后合并的时候,根节点都为0 
					temp1=0;
				}
				merge(temp1,temp2);
			}
		}
	    for(int i=0;i<n;++i)
	        if(getf(i)==0) ++cnt;//这个地方要用getf(i)==0来判断该节点的根节点是否为0,因为f数组里面存的不一定就是它的根节点, 
	    printf("%d\n",cnt);      //有可能是他的某一个父节点(这里我说的父节点,可能是他的爷爷节点,或是父亲节点,或者继续向上,但不是最后的根节点) 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值