PAT A1005 Spell It Right (20)[拼写正确,字符串]

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification

Each input file contains one test case. Each case occupies one line which contains an N ( ≤ 1 0 100 \leq 10^{100} 10100)

Output Specification

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input

12345

Sample Output

one five

思路1

  1. 读入字符串,逐位数字求和,将结果转化为字符串
  2. 输出对应结果字符串中字符对应的英文单词,输出时注意控制空格

代码1

#include <iostream>
using namespace std;

string words[10] = {"zero", "one", "two", "three", "four", 
                    "five", "six", "seven", "eight", "nine"};

int main()
{
    string s;
    int sum = 0;
    cin >> s;
    for(int i=0; i<s.size(); i++)
        sum += s[i]-'0';
    s = to_string(sum);
    for(int i=0; i<s.size(); i++)
    {
        if(!i)
            cout << words[s[i]-'0'];
        else
            cout << " " << words[s[i]-'0'];
    }
    cout << endl;
    return 0;
}

代码2

#include <iostream>
using namespace std;

string words[10] = {"zero", "one", "two", "three", "four", 
                    "five", "six", "seven", "eight", "nine"};

int main()
{
    string s;
    int sum = 0;
    cin >> s;
    for(auto &c : s)
        sum += c - '0';
    s = to_string(sum);
    cout << words[s[0]-'0'];
    for(int i=1; i<s.size(); i++)
        cout << " " << words[s[i]-'0'];
    cout << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值